Need help with Apogee Centaur Major

Speaker started buzzing and giving off a rattling sound in the center of the ribbon and the woofer. I see no physical issues at all. If anyone knows anyone that has experience trouble shooting this speaker please let me know. I'm in Augusta GA. 7069556385
Try and post on the forum, they should be able to help out.
I wouldn't automatically classify this as a speaker issue. It probably is, but I would eliminate the rest of the system before spending any money. In your post, you don't say, but it looks like the problem is with just 1 of the speakers. If that's true, unhook the speaker cables at the speaker end only and swap them. Left speaker cable is not on the right speaker, and the right is now on the left. Don't make any changes at the amp. If the sound is still coming from the same speaker, that would indicate an issue with the speaker. If the noise follows to the other speaker, the problem probably lies elsewhere.
Rsjm80, Ponnie, might not be able to help as, in the past, he has clearly stated that there are no replacement ribbons for Apogee hybrid speakers viz. Centaur & Slant, etc. He might have changed his stance recently but that was the case so far. Doesn't hurt to ask but just a heads-up....
The woofer ( Vifa in most cases for the Major )has probably come unglued from the surround. Not dry rotted, just come unglued. Remove the woofer grill cover using upholstery tools and a lot of patience and the woofer cone can be re-glued to the surround. A very few Majors had foam surrounds and replacements can be had for about $40 ( labor to install not included).

Graz in Austalia DOES sell replacement ribbons for the Hybrids. The parts he does not sell are the woofer panels for the Stage and Studio models. The site lists $405 for a pair of replacement ribbons ( again labor not included ).