My North Star DAC -not picking up Toslink from STB

Hi Folks:
I just bought a North Star Transport and DAC combo and am very happy with everything. However, with my old DAC I was able to easily connect my DirecTV STB tuner to my DAC (A Bidat) via toslink and get sound that way. With the North Star, somehow the DAC is not picking up that signal. More confusing still is that I tried another transport, and the Toslink is working fine there (DAC is picking up the signal). So, I'm guessing something may be awry with my DirecTV Toslink output? I do see a red light generated at the input end of the toslink cable, so signal is going from the DirecTV STB. Can anyone offer any potential remedy.? the Direct TV STB only has that one digital toslink output, so I can't avail of other outputs. Might there be some issue with the cable? Anyway, I'm hoping some of you would have suggestions on how to remedy this. Thanks in advance!
When you try it, make sure you are sending a PCM (stereo) digital signal from the STB, not a Dolby Digital signal. I've tried using a DAC with a STB only to find out that my STB can not be set up to output PCM. It only outputs DD, so it won't work for me.

Obviously it worked for you before, so your STB can output PCM. Just be sure it is PCM when you try the Northstar.


Gongratulations on your newly aquired Northstar combo.I got it too.Happy listening,sorry can't answer your question though.
Hi Reubent:
Thanks for the info. I'm sure you're onto something. The audio settings I found on the screen menus are very redimentary (audio language and dolby on/off - for programs with dolby programming). There doesn't seem to be any other menus. I'm still getting no audio. it's so strange. Could it be possible that my previous DAC (the Meitner BIDAT) was somehow able to pick up the connection but this North Star DAC cannot? It's soooo frustrating, as I really only bought the North Star setup to act as my digital 'hub', and the through of resorting to analog cables from my STB, and the associated noise, would break my heart. Please help!! ;-(
Well, what do you know. I hadn't but finished the last message, and I hear some subtle sputtering sound from the living room. The sound stuttered a bit and then came to life. I'm getting the signal from the STB now. All is well. Soo bizarre. Anyway, I'm good to go. Ahh, bliss. Thanks for the help!!
Just don't unplug it! I had a similar, strange experience when hooking up my Behringer DEQ2496 equalizer. When I plugged in my Airport Express, bad sound came out; later, nothing came out. When I plugged the AX into my DAC (Northstar!) instead, it was fine. When I ran the AX into my Monarchy DIP and then into the DEQ2496, it was fine. At one point, out of the blue, the AX -> DEQ2496 configuration started working normally. Later, it stopped again. I haven't tried to figure it all out, since my preferred chain of AX -> DIP -> DEQ2496 -> Northstar DAC works fine. But it sure is puzzling.
I had a very similar situation last month with my Samsung STB to Marantz SR 8500 using toslink. And I discovered in much the same way you did--by changing out a component.

What I eventually found is that the toslink cable was the culprit! If subjected to the slightest "jostle" it would drop signal. Another jiggle and the signal would restore.

This wasn't conclusive enough to blame the cable, but I decided to swap it out as a way to isolate it as a cause. I expected the STB to be the problem (it's older, runs hot, and sometimes gets a bit 'quirky').

After I replaced the toslink cable, the problem disappeared. I assume that had the problem been with either component, the issue would have remained. Nevertheless, because it was an intermittent problem, it took some waiting before I deduced that the cable truly was at fault.

Looking back on 30 years in this hobby, I've only had one actual component fail, but have gone through many cables. Ironically, it's usually the last thing I check (sound of palm smacking forehead) when troubleshooting!