my cj 2300a........

came on by itself with the switch in the off position, and now wont turn off or power down. has anyone ever heard of this, or had it happen to them. please let me know asap, we don't use this amp that much to have something like this happen to it. I will be calling keith at cj on Monday. just want some headsup to see what is best for me to do, cj has become to expensive......thanks
It's probably a defective power switch that has "opened" up. Just a guess, but that seems likely.

Just plug and unplug the unit from the wall until you can get it fixed.
thanks, mofimadness, ill look into it, cj closed today...
I've replaced the power switch in my 2300A with the same symptoms as yours. It's actually fairly simple to do. 20A, 125-277 VAC CARLING 0716R switch. Any competent local tech should be able to replace it if you are not comfortable doing it yourself. Shipping the heavy amp back and forth to CJ can get pricey.
I experience this once with my CAV50. I had to unplug the unit to get it to power down. I boxed it up and took it to my local dealer to have them take a look at the switch. Once I arrived at the store and we plugged it in , the power switch worked fine . We assumed it was from the ride down in the car and from maybe moving it around. It has worked fine ever since then.
See what happens over the weekend. Try exercising the power switch from time to time. Maybe you have some type of debris in the switch assembly that might work itself out. It won't hurt to try!
If you still have the same issue , you can call Conrad Johnson Monday and see what they suggest.
ok guys will do, talked with my local guy he said pretty much the same thing..............