My Cary amp - the story of a hum and a bug


Hi,
I have had a problem with my Cary SA200.2 power amp from the time i bought it 3 years ago. There's a hum from both speakers (doesn't increase when the volume is turned up). The hum is there irrespective of the connected preamp or power source and even if i take the amp to another city or location. I was told by the dealer that such a mild hum is normal in such a powerful amp. It was only later that I realized that a solid state amp with a toroidal transformer, however powerful, should not have any audible hum. By then, it was out of warranty.

With the help of the India dealer, I wrote to Cary in the US. From their delayed and intermittent responses, it appears that the hum is a known issue, inherent in the design of the amp, that needs a 'fix', which is taken care of in the newer model of the amp. The 'fix' consists of a cable with caps and a bridge rectifier. Shockingly, they expect that I should pay around $210 + duties for this. To me, it is not a question of money, but one of principle! Why should I pay for them to fix a bug, even if the amp is out of warranty? I even suggested that it will not cost me more than $30 to build the cable here in India if they can send the diagram and component values for this fix. But Cary is adamant that I either pay for the cable or trade in my amp for a new +1 model!! In desperation, I requested that they send me the service manual of the amp, hoping to address the bug with the help of the manual. Back comes the reply that it is proprietary and that they cannot share it with customers. The dealer has been unable to exert any real pressure on Cary to resolve this issue.

I would like to know, from fellow FMs:
1. Is Cary justified in it's stand?
2. Role of local distributors/dealers?
3. Does any other FM own a Cary SA 200.2 and how he has fixed this issue.
4. Can the electronic experts suggest the specs to filter out the hum?
5. Will adding this filter adversely affect the sound quality?

CUT TO CHINA:
I have a Chinese made integrated amp (Kinki Studio). It is no slouch, having been awarded the Blue Moon award by none other than Srajen of 6moons. I blew the amp some time ago by an incorrect connection. It was my fault. But within minutes of sending an email, the dealer in Singapore was on whatsapp chatting with me, asking for photographs, communicating with the manufacturer, suggesting diagnostic checks. Within 24 hours, they realized it could not be fixed via distance communication with a non-electronics-trained user like me. Within a week, a pair of new power amp boards arrived by DHL, shipped at the dealer's cost, with detailed instructions on how to replace the boards. The only cost I incurred was the cost of shipping the old boards back to them for diagnosis. So I guess Xi Jinping wins this round :) 

Thanks for reading
fiftyfifty
Thanks for the responses.

I realize now that there are others like me who have not had too great an experience with Cary Audio. Some of you have had to deal with worse situations as compared to my hum issue. I realize that the dealer too is to be held accountable. But as a customer, I see the company and its dealer as a single entity. It is for them to communicate and sort it out with each other to resolve my issue. 
I've been able to find a technician who is confident of eliminating the hum. I don't know at this stage whether it will cost me more or less than what i would have to pay to Cary. But, like I said earlier, it was never a matter of money.
Cheers!
@fiftyfifty wrote....... I do grant that Cary Audio has responded to all my mails and have been reaching out to help resolve the issue. But on their terms, which are not acceptable to me. In their latest mail received yesterday, they have now agreed to build the harness at their cost provided I pay for the shipping. I suppose this is a fair proposal and will take it forward with them.

Why didn’t you take up Cary’s offer to send you a harness at their cost if you pay shipping?

Why didn’t you take up Cary’s offer to send you a harness at their cost if you pay shipping?
Because as soon as I softened my stand and agreed to their proposal they completely denied that there was any inherent problem with the amp, alleged possible misuse, denied having ever sold the amp to an Indian distributor (the distributor says he has now taken this up with the Cary CEO), wanted me to, in a way, reverse my position on this thread and generally accept on this AG thread how 'helpful' Cary had been! Interestingly, Cary's offer of replacement came only after I started this thread. So, thank you Audiogon :).
All this without any guarantee that the issue would be resolved. I'd rather go to a technician who is confident of getting rid of the hum. 
I wish to repeat that Cary products are excellent, but history has shown how legacy companies slip into this kind of complacency on service and innovation fronts.
Cheers!
I owned that same amp.  I had the same problem as you.  I emailed them and got the following response:

"If you look at the picture, this is the inside of the SA-200.2 looking at (1) amp module. You will see I have circle (3) wires connected to the PCB board in pink. Disregard the circle in red because it doesn't apply. We have learned the manufacture of these connectors used oil film coating on them for storage

When the connector are plugged into the board sometimes the metal doesn't make a good connection. To make a better connection we would pull the connectors off and push back on once or twice. By pulling off the connector and pushing back on the (2) metal pieces scrape and dig into each other making a very good connection.

There are (2) amp modules. So one would have to do this for both channels."

I did what they suggested.  It did not resolve the problem.  I ended up selling the amp.  Cary Audio is not the company it used to be.  While I still use a Cary SLP-98P preamp, I certainly would not buy a new product from them.
I owned that same amp. I had the same problem as you
What a pity!