modwright Sony 999es platinum truth.

This is my reference cd player,has been for 6 years.The other night while looking up reviews for this player a reviewer said there are things you can do to this player to make it sound better.He said hook it up to video monitor (a TV will do) and turn off light display,make sure all digital sound outputs are off. So I hooked it up to a TV and went to menu and turned off display and all the digital were off but in the audio settings there were to settings was a standard setting and a WIDE RANGE setting and this unit was on standard. So I put it on WIDE RANGE and put it back into my system. WOW the extension in the upper range and the bass bloomed. I could not believe the difference the music just flows uncumbered.I was blown away not to mention the low level detail is unbeleivable. If you own a Sony player check to see if it's on standard and if it is switch it to WIDE RANGE a listen for yourself,it's like night and day
Here is the article. When I said shut off all digital I mean 5.1 dolby.
I think on mine Standard is a filter and WIDE RANGE REMOVES IT.
Glad you found that, it really does open things up!
Now if you could just find a way for mine to play the SACD layer of hybrid discs, I would be forever grateful. I have had a new laser assembly installed, which did nothing. Otherwise, I still love love love this player.
There is a SACD setting in the menu have you tried playing a SACD disc while you have the menu engaged? It could just be off.
Qdrone, where would that be? I just went through the whole menu and didn't see anything like that.
I'm so hoping it is that easy! It used to play them, but not any more....
What machine do you have 999es? It's either page 41 or 47. It's titled making room for SACD.LOOK IN THE TABLE OF CONTENTS.
Go to Sony and download your Manuel for free. Then do it.
Thanks for the info, but that didn't work. The 999 refuses to read the SACD layer of any hybrid discs, although it plays stand-alone SACDs fine. Very frustrating, as most SACDs are hybrids.
I had the exact same CDP and I found that it played most SACD's but not all.
Try another SACD and see if it will play that one.
Good suggestion! I tried that, here's what it does:
It plays ALL SACDs, it play NO Hybrid SACDs (discs with an SACD layer and a CD layer).
I had the same problem others have posted here. My 999 stopped playing hybrid SACD's after a very short time. I sent it back to Dan Wright and he replaced the laser assembly. I got it back and after a month or two it did the very same thing. It plays non-hybrid SACDs fine, but not the hybrids. I play a lot of SACDs so i had to replace the player. I still have it. If anyone wants a very good player with a Jena Lab upgraded umbilical and tube power supply cheap, let me know. Great player, but the SACD problem was frustrating.