Memory playback worse than disk... Why?


I'm used foobar, now jriver to connect my new toshiba portege r830 (i5,4g ram, windows 7 64-bit) to my Dac via USB

I play 24/96 flac files, stored on a buffalo nas.

To even get close to near absent jitter, I use wasapi event mode (better than ks, wasapi,...), exclusive mode for Dac, and clear the buffer before each track. I also increased the priority if the jriver process.

When I elect to playback my files from memory (file uploaded prior to playback), I get these big crackling noises upfront, and experience more jitter than by playing direct from the nas disk. Why?

Poor laptop design, windows design, settings ?

P.s. I'm amazed how complex it has been to make 24/96 work (and it's still not perfect).
Check your buffer settings for JRiver... test with them set to minimum as they may be fighting each other. I've had the issue before with wasapi, seemed hardware buffer linked
I have experienced exactly the same phenomenon you described (just effects are minor). I think that Davide256 is correct in that wasapi seemed hardware buffer link.
I solve this problem and improved sound quality by using ASIO and not wasapi or wasapi special.

In addition, FLAC sonically is bad format and will increase all artifacts too. why not to use WAV ? if everything else is set up correctly you will hear immidiately big difference bewteen two formats ( I use powerful computer also)

2 thumbs up Simontju to your opinion on FLAC. When FLAC is the option and not WAV on high rez downloads I always convert to WAV after... added processing for FLAC decoding seems to add jitter/ loss of clarity in playback on my dedicated music server.
@ Simontju

FLAC is not a bad format. Get a better computer, build a real media server, drop the USB connection and get a Bit Perfect sound server. If you can find someone to build a Linux server for you then go for it. Don't blame the format if your computer cannot handle it.
I also believe JRivers buffer setting to be the problem. I agree that FLAC is not a bad format, but to my old ears, WAV sounds better. You can argue formats all day, but in the end, listen to you're own preference.
Mizuno, I switched back to foobar 2000 and problem was solved.
See my post here, which describes a fix that I suspect stands a good chance of being applicable. That solution did in fact solve the tics/pops/skipping problem the OP in that thread had, with a Windows 7 laptop playing audio via USB.

-- Al
FLAC is not a bad format. It's just 1's and 0's. It's how you read those 1's and 0's and pass them to your speakers that is the culprit.
" FLAC is not a bad format. It's just 1's and 0's."

When did I hear identical argument????
Oh in 1982 when CD Players were introduced...

People must go more frequntly to acoustic concerts and/or wash with soap their ears so they will know what they HEAR not what they read in smart manuals.

" Don't blame the format if your computer cannot handle it.

Should I comment? Did I disclose to anyone (except Alex Peychev of APL HiFi) my computer? Nope! I will be silent like a fish!

Just tried to help OP - I had identical problem, solved it and explained how. Also not good; somehow stepped on some egos.....Brrrrr

Oh, if someone wants to use lossless compressed format then APE is much better sonically then FLAC. Particulalry with hi-rez (e.g. 24/176.4) files. The 16/44.1 is really not a challange today
agreed on both windows and BIOS power settings... wake from sleep state is bad for audio reproduction. Unfortunately laptops tend to be less diverse in changing BIOS options that could help since they have to focus on battery life preservation.
There's no technical reason why your choice of software and formats can't work properly when you get the setup configuration worked out.

Follow Al's suggestions. Also download and use this tool to test for other system interrupts that can be inducing latency issues.
Just change the setting in J River to 32 bit instead of 24. That worked for me. I had a similar issue.
Hi Mizuno,
Did you get your issues solved? What have you discovered?