Melos SHA Gold - what may be the fix..

for my preamp that will not come out of mute mode?

Remote control must be used but can get no response from "power" (in effect the on switch). The manual descibes as "play mute off". The remote does still control the other functions such as volume motor.

What may be the problem and what techs should I consider sending the unit for repair?
Let me tell you how difficult it is to find parts for melos equip. I have a sha gold with the opposite problem, volume contol is not working. So let me ask you this question are you looking for a sha gold for parts or willing to sell yours for parts? Let me know. Thanks Ray 401-597-0364
Thanks for the offer(s),Ray. I am not quite ready to throw in the towel yet. And I do not have the ability to service
my own.

In a way I was fortunate to have my first issues with the preamp early in my ownership. Sent it back to Melos and after some strange twists it came back repaired. I enjoyed it for a few years of fairly light use. Recently, it only stares back at me. No starting and no more music.

I will pursue repair service for the immediate future.

Still requesting information from anyone who may know of
a servicer who may be able to handle this excellent (sound)
piece of equipment. So far no response to my email to George Kaye.

I have a Melos SHA Gold and whenever it goes on Mute, i put my headphones in and pull them out and it goes out of mute.

Mine has been modified by Melos Audio Restoration so that might not be applicable, but just a suggestion.

Also, you might want to check out this website:

Dear audiongon brothers and sisters, afriend is in need of our prayers. Please pray for Randy Young, as know he would do same for us, Randy is not well and needs our prayers. Thanks Ray Lippe God Bless Randy AKA "ezekiel"