McIntosh MX 132 issue

Hi all,

I would like to appreciate for your time and your advise!

My preamp MX132 is connect with only one amp which is MC7106. They worked pretty well until my little boy messed them up two days ago.

Now I turn MX132 on by remote or the "Stand By/ On" button on front panel. It stay for 2 to 3 seconds with MUTE message at LCD, then it shuts off by itself.

I tried to play around with it and I can make it stay on with "Remote Zone" message at LCD, but remote control cannot control it any more, and NO button on front panel working accept "Stand By / On" button and power switch (to turn it off).

Hopefully, one of you can show me how to fix this issue.

I would like to appreciate for your time and your advise!

Unplug the preamp for a few minutes.
Just the preamp should do..
Then plug them back in.
Often the internal 'logic' can 'go crazy' and get stuck. Unplugging them can allow it to untangle itself.
If it still does not work. Then check in the owner's manual to see if the preamp has a special set of functions to reset the preamp.
Usually it is holding one or two extra buttons when you turn on the item at the powerswitch on the item.
I agree, unplug the unit and while it unplugged, individually press all the buttons on the face plate.
That will drain any stored capacitence and release any memory lock. Then plug it back in. I have owned a number of McIntosh pre-pros including the MX132 and this has always worked for me.
Elizabeth and Theo,

I appreciate for your advises. I have tried few times with your advises, but it still does not work!!!
The mcintosh maual just show how to operate it. It does not have troubleshooting session!!!

Unplug the power for a couple of hours and remove the fuse if there is one.
Also I would add to Cnote's response, disconnect all your connectors and repeat my suggestion of a de-capacitence.
If not give McIntosh a call. One thing that might help is give us an explaination of just what your son did. Did involve water/fluids, sudden impact or shorting of wires??
This may have a direct influence on the solution suggestions.

I appreciate for all your advises. I made it!!! It is working fire now! I am so happy.
I google and got three steps to try it.

1. Soft reset - Unplug power cable .... as you adviced
2. Hard reset - Device off with power cable. Hold down "System Off" and "Late Night" buttons for 30 seconds - we will see all LED on and REMOTE ZONE message
3. Call McIntosh - we might have to re-flash our preamp with the file from McIntosh (will take us time to do it).

I got it work by hard reset - but I hold buttons to 60 second (even I saw all LED on as I wish).

I would like to say appreciations to all of you.
Best wish.

Hito-Glad you got it back. That hard reset was lost in my mind for years. I never would have remembered that, I guess it is failing aging mind that I am left with for resource.
Thanks for letting us know you have it working again.