McIntosh MS300 Start up Problem

The MS300 worked fine until yesterday.
When I turn it on it will not start up. I get the starting up message and then a connecting to server message. But never get a non-flashing red light.

I have reset the unit by press the red button for 4 seconds and still get the same messages.

This even happens when the MS300 is disconnected from the internet.
You may want to try unplugging it from the wall for approx 10 minutes (if no lights are flashing, etc.).

Another option is to call the direct # for MS300 service which is 866-458-6910.

Were you able to fix you problem? Having the same problem with my MS750. I believe my bios is stuck. I don't know how to reset it.
I had the same problem and had to send my unit to New jersey for repairs. the only authorized service company for the McIntosh units. The repaired the unit just fine. The name of the company is Panurgy OEM, 973-625-4056. They also upgraded my MS 300 to the MS 750 capability. They take a little while to repair and aren't very good in keeping you up to date on status, but if you don't mind contacting them routingly, they are the only ones authorized by McIntosh to repair the units.