Magtech amplifier over heating.

I bought a magtech amp a few years ago and have had to send it back twice in less than a year. The Motorola thermal track transistors are not reliable. When the thermal sensor goes the amp will become very hot even in idle. The left channel failed back at the beginning of 2015 and then the right channel failed in October.The amp still worked but the heat sinks were very hot even at Normal listening. Roger has no problem with fixing the amp. But how often is this going to happen. I have an Aragon amp that I've had for 30 years and only had it repaired once due to my negligence. Has anyone else have this problem.
I had a Sanders ESL amp for almost 6 years and never had a problem with it.

Roger and Angela are fantastic people and will always take care of you. Also their product has a lifetime warranty.

Sorry you've had problems, but just be glad that you had this amp and not some other that only offered a few years of warranty and would have cost you to fix it.
negotiate with Roger so he'll give you another amp and your amp he'll keep on fixin' indefinitely. this will save lots of money shipping it back-fourth. test Roger if he's good enough to make that happen.
You need to know that ThermalTrak have had a bad reputation for failures and SOME models were allegedly discontinued a few years ago.

I suggest you read this thread for a typical discussion, but keep in mind it's also true that some other models may be back or are still in production, for example see

Then read up on Viola claiming to be getting "low yield", meaning, a lot of dead wood; but the units that did pass QC have had no problems.

The point being is that you should talk to Roger and figure out best course of action, loaded with this info: what models is he using, what's his QC process, why so many failures in your case, etc...

I have also found out through the years that the more expensive amplifiers tend to have a lot more device-matching done on them, and a lot more QC; but this statement is not universal (e.g. have witnessed all too many expensive tube amps blow up and take speaker drivers with them).
I bought one about 2 years ago...It failed shortly after I bought it, and I sent it back. Roger sent me a new amp as he was waiting for a part . The new one failed a bit later , and back it went again.

It runs warm at idle, which I was surprised about, as owners and reviewers commented on how cool it ran. One of my cats loves to sleep on it, as it is like a heated bed!

When operating, it tends to be very warm, and when I listen loudly, it is so hot you can't hold your hand on it for long.

Roger told me that it was being overdriven, as I have Magnepan 3.7's and he stated they are very inefficient, which is so.
I've since turned down the volume, and so far no issues, but the shipping cost for repairs tends to balance out he great price, as does being without an amp for a few weeks.
I love the sound, and have even considered the mono blocks...should it fail again, I'm sure I would discuss other options with Roger.
He stands behind his product, surely.

If it's a QC issue, then maybe my ownership will be shorter than I planned.
A tough call.
So which manufacturer is better one with poor design but nice or one with solid design but not nice?
I showed Roger this thread and he composed the following response for you. I hope this helps. cheers, Angela

It is true that a small percentage of Motorola's 4000 series Thermal Trak transistors develop faults in their thermal sensors. This causes the bias in an amplifier to increase and that channel will run hotter than normal. Fortunately, the transistor itself works properly so the amplifier continues to operate normally with very low distortion.

Unfortunately sensor failures do not occur immediately. The fault does not appear until the amplifier has been in use for weeks or months. As a result, there is no way of that a manufacturer can identify a Thermal Trak transistor that is prone to failure during his quality control and burn-in process.

Motorola has responded to their problem by discontinuing their faulty, 4000 series Thermal Trak transistors and replacing them with a new version. We here at Sanders Sound Systems have been replacing the original faulty transistors with the new ones and so far we have had no failures in the new transistors.

However, the new transistors have only been available for a few months. Before that we had to replace early faulty 4000 series transistors with more 4000 series ones. This resulted in some customers having more than one failure. This should no longer be a problem with the new transistors.

Only a small percentage of the original 4000 series transistors failed. Most Magtech customers have had no problems with their original transistors and their amplifiers continue to operate perfectly. So Magtech customers who are not having any transistor problems need not be concerned.

The bottom line here is that Motorola has taken action to fix their Thermal Trak problem. So we should not be seeing such failures in the future. Sanders' customers can rest assured that Sanders will fix any Magtech amplifiers affected by Motorola's transistor problems at no charge under their lifetime warranty.

Great Listening,
Nice to see such a reasoned and considerate response to the situation from Roger. Always good to see a company that continues to support their customers and their products especially when a problem arises. I'd like to see more manufacturers act in such a responsible manner.
Yes, Ive had a pair of the monoblocks for some years now, serial #00352, that I run some Magneplanar 3.7 speakers with.
I noticed a few weeks ago one side of one monoblock running extremely hot, initially thought it might be a ventilation issue but after eliminating most of the variables it still runs very hot. Even with no load, it warms up very fast from off state. The amp still works OK and no other indications of any problems.

It sounds like I might have the same thermal track tranny problem.
I hope my local support, Bill McCleans Hi Fi,  can fix it. I'm in Australia.

I know Coda has made some changes to that Circuit in recent months... Might be worth giving Doug a call.  He will talk openly and honest, then you can follow up with Roger. 

Good Luck


Knowing Bill I’m sure if you point him to this thread he will get the replacement of the unreliable thermal sens transistors done with new ones and instructions Roger will send him. From what I see, they could be the little ones mounted by themselves on the heat sink on either side near the back of the amp, and don’t look too hard to replace, maybe without a dismantle job if that's them.

Get both amps done, and I suggest you don’t use them till they’ve been fixed, as over heating in the longer term spells slow degradation for any amp.

Cheers George