LINN MAJIK - Remote Problem - Anyone experiencing.

Linn Majik Owners, having problems with remote - weak signal always.Is it normal?.
I changed the batteries and you still have to be around 6 feet or closer to get it going for Vol up and down. Wont work otherwise. Frustrating of course. Bought it used, the unit itself. Its a linn remote if you have doubts.

Is that normal? It sucks but I can not see that as a normal design. What else could be the problem?

Hi Ravi, I have owned the Majik and now the Classik and I have been able to use both remotes from as far away as 13 feet without any issues. I use the Classik as a backup so if you need to borrow my remote to try it, please drop me a line. BTW, did you ever get the jumper from Linn? The one that adjusts the turn on volume to 15 instead of 30?
Please keep me posted.
Thanks, BJ.
I don't have any experience with the Majik and only a little with a Classik but, as a thought, if it's the remote itself that's putting out a weak signal you could try a relatively inexpensive learning remote of another brand. Since the Linn remote codes probably won't be available for automatic programming, you'd need to 'teach' the new remote the various commands using the old remote. Once you understand how that works it takes only a few minutes.

I've used the Sony RM-VL700 and RM-VL900 with several brands of exotic audio gear and they've been an improvement over the original remotes in every way, besides being able to control other devices in the system at the same time. The 700 is discontinued but is still available online for around $30.
As a Linn dealer, I've never experienced such kind of problem. Did you check if any infrared source is on? Some low consumption lamps can give a lot of trouble with the remote sensor.
I have that problem when my LCD TV is on. When the TV was within a foot or two of the majik the remote hardly worked at all. Now I have the TV mounted on the wall and it's at least 3 feet away, remote works a little better now.