Krell FPB300 - mechanical transformer noise.

I have an FPB300 that does not have the pinging issue discussed on another thread - my problem is a noisy transformer. I have measured approximately .75 volts of DC on my incoming line (dedicated 30A) and plan to try a DC trap such as PS Audio's UPC200HB.
The unit makes the most noise and is most noticable when the music stops or when the music transitions from loud to very soft - unit almost growls for several seconds and then fades away. I am assuming that this is related to the class A biasing scheme. Krell had no suggestions even after I asked if DC could be saturating the transformer - they acted like they never heard of toroids and DC issues. I am feeding the amp directly with a Wadia 850 (balanced) and it is driving Apogee Duetta Signatures (Audioquest Midnight Cables) Anyone experience this or have ideas? I am very happy with the combo except for the noise. Thanks in advance for any help.
Did you e-mail Jim Ludoviconi he is the Assistant Vice President of Sales and Marketing & Director of Technical Support. He seemed to answer all my Krell questions very knowledgably.

Thanks - I will do that. Jim is not the person I spoke with. Instead of using "they" to refer to Krell, I should have referred the person in technical support. Hopefully Jim can shed some light on the cause.
You may want to open it up and tighten the transformer. Don't overtighten but with it heating up and cooling off it may need to be cinched down again.
I don't think tightening will help the transformer. It is probably a bad transformer or a bad filter capacitor. It would be best to send it to Krell for evaluation. You can check for DC leakage from the Wadia. Krell does have a setting for tube preamps that may help in this case.
It's not unusual for transformers to hum. This can occur when large harmonics are present on the AC line. I had this problem with a CODA amplifier and called my local power company out to check the lines and they found that the 10KVA transformer on the pole was going in and out of spec causing higher than usual harmonics and voltage swings. Fluctuating voltage can cause this as well. Most transformers like to work at 110 VAC. When your line fluctuates more than 15 to 20 percent you may notice a hum in your amplifier.

Filter caps can cause hum as well, most output filter caps internal to amplifiers are good for at least 10 years, that's not to say they don't go bad sooner than that. Its just a lot easier to have your local power company verfy the specification of the power than it is to pack up and send a 150 pound amp back to the manufacturer.

If it is your power, you might wind up sending it back and they won't find a problem with it, because their power is fine. Good Luck, Indiana_Jones
Just an update. I found a reasonably priced (used) UPC200HB and the mechanical noise disappeared immediately. Now I'm left with the nagging thought that even though the conditioner is non current-limiting it could be affecting my overall sound - can't quite put my finger on it but I will give it some time and listen under relaxed conditions to be sure I'm not imagining it. At least this points to something in the incoming power whether generated inside the house or from the service. I will try to track and eliminate the cause of the DC which will allow me to run straight from my dedicated lines.
In the meantime I will make a VH flavor4 cord to connect the UPC to the wall and enjoy the quiet!
Thank you for your responses.
Landshark75:How did you measure the incoming DC? what settings on a volt meter?

Indiana_jones: How did you get the electrical company out? My voltage flucuates (My APC ups tracks this) and I've got huge noise problems in my house.

I used a Fluke (I believe model 23) multi-meter set on the DC setting with the decimal at the hundreths. On another occasion I opened all the breakers except the dedicated lines to find a possible in-house cause but was interrupted when the wife came home, saw the power was off and gave me one of those looks!

To clarify, I measured at the receptacle on the dedicated line. I could be wrong but I still haven't ruled out an in-house cause simply because I have dedicated lines since all circuit neutrals and grounds are tied together at the loadcenter - any electricians out there?
You have a grounding problem and you need to get this fixed immediately in order to prevent damage to the amp and other components in your system, humbuster or not.
Please elaborate on your diagnosis of a grounding problem - The equipment has been operating for months without any problems other than the transformer noise. How does DC on the line relate to the grounding? My understanding is that it can generated from outside by faulty utility equipment or internally by motor loads and low voltage lighting transformers.
Transformer noise usually implies a bad transformer or at least a noisy one. I had to send an amp back to Krell years ago for the same problem. I was told they got hold of some bad transformers from their supplier. Mine was brand new so they replaced the amp. It could also be a bad filter cap but it is not as likely.
Excuse if this is irrelevant, but my system (amp and pre) developed a sudden transformer hum a few months ago. It was fine, then I shut it down to swap power cords. When I brought it back up, fairly loud tranformer hum from the amp and the preamp. Well, it was more of a transformer squeal from the preamp. It actually took a few days to sort. I was telling my wife about it and she mentioned she had plugged in our humidifier about the same time. I unplugged the humidifier, and the hums were gone.