krell 400xi intergrated remote problems HELP

i bought a krell with remote and put the battery in press pre and nothing what's is happening HELP
Why would you press pre for an integrated amp? But make sure the power switch on the back of the unit is on.
double check to make sure the battery is in correctly (not backwards)?
Also, make sure the battery is in correctly. I've had no problems with mine.
First, check to make sure the battery is O.k. with a volt meter or DMM. Make sure the voltage is above what is engraved on the battery. If its close or below, replace the battery. And make sure you install it correctly.
If that doesn't work, remove the battery and press every button on the remote, one at a time, holding each for a couple of seconds. Correctly install the battery and give that a try.
You're correct about needing to hit the Pre button, I've heard that sometimes you have to press it each time before you try to use it, but I think that was just the first ones, mine isn't like that.

Hope this helps

I had exactly the same problem. The battery was placed correctly and the coltmeter measured 2.8V which should be OK. However it did not work. You can try to use a digital video camera to see the infrared light. My Sony camcorder can see infrared light and I use it to test remotes. No light was seen. Since I bought the amp new I did not suspect the remote yet.

Then finally I bought the Duracell DR2025 which has 3.1V output and it worked fine. The Krell remote needs a voltage above 3V and I found that only the Duracell DR2025 worked with this remote.

Measuring a battery's output with a voltmeter is not accurate because there is no load on the battery. You should use a battery tester or voltmeter with a battery setting.