Jeff Rowland Amplifier Help

I think I blew a fuse on my Jeff Rowland Model Ten amplifier and can't locate where they are. The manual doesn't address it and Jeff Rowland is closed until Monday. Any Rowland owners that can help? Everything else works fine and I have isolated the problem to the amplifier. It lights up but no power, thanks for any help.
The fuse on my Jeff Rowland Concentra Integrated Amplifier is located immediately below the power plug connection. There is a very small black rectangle shaped box that contains the fuse (look right below the area that you plug the power cord into). Please be careful pulling the plastic cover off, but once you do, the fuse is right inside this box area. I hope your Model Ten amplifier has the fuse in the same location. Please replace the old fuse with a new one using exactly the same rating (Radio Shack should have a replacement fuse). I do not understand what you mean when "it lights up but no power". My unit also has had blown a fuse and the unit would not turn on and and all lights were off. I hope this helps. cheers....
I have a Model 10 that has done the same. When this happened to my amp I had just powered it off so I could change cables. The amp seemed warmer/hotter than usual before I powered off. When I turned it back on the light on the amp came on but no sound. I checked everything in the system and it was definately the amp that was the problem. I checked the breakers on the back of the power supply unit (no fuses) and they were all good, none of them had tripped. What I did to "fix" the problem was to powered down the amp and then unplugged it from the wall AC. I let it sit overnight to "cool" off and crossed my fingers . The next morning I powered it backup and it worked fine, music again! Not sure why this happened but it hasn't happened again. My guess is that the amp unit overheated and thermally shutdown.
Greg Burnett
Technical Service,
Jeff Rowland Design Group, Inc.
tel: 719-473-1181
fax: 719-633-4158
I spoke with Jeff Rowland and sent the amp back to him, he replaced the power supply with an updated version at no cost. Again, great customer service from an exceptional company.
Thanks for sharing, you help us all!