iTunes can't find Network Storage

I am stumped by this problem.

Had iTunes on my old HP PC with music library of about 40 GB stored on Network Associated Storage (Netgear Ready NV+). Usually controlled this using SONOS...worked great. New ripped CD's were deposited in right files in NAS iTunes volume. Everything great.

Then my PC got stolen. Now have new HP PC with iTunes 8.0 and want to access the NAS hard drive iTunes music files. But nothing seems to work.

In iTunes Edit/Preferences/Advanced/iTunes Music Folder Location I use browse to insert the network location \\\iTunes. iTunes hangs up. Always hangs up when I try this.

When I press on the left sidebar Shared iTunes Server...nothing happens.

For whatever reasons, the new empty iTunes software does not see and will not access the NAS iTunes folder.

BTW, Apple tech support tells me they do not support iTunes. Lovely.

Any suggestions...what am I doing wrong?

"" should undoubtedly be ""; not sure if that is a typo -- if not that is definitely part or all of your problem.

Also, can Windows see the NAS (under "My Network Places" or "Windows Explorer," or whatever Vista's counterparts to those things are -- I'm an XP person)? If not, have you set the workgroup name for the new computer to be what it was on the old computer?

-- Al
Also, if your NAS is assigned an ip address by a dhcp server in your router or whatever (as opposed to having been manually assigned a static ip address), it could now be assigned a different address than it previously had, as a result of the new computer being on the network.

-- Al
I think Al hit on the most important problems. CHECK those first. How many computers do you have on your network? Can any other computer access the nas if you have more than 1? Another thing to try is disconnecting all other computers and running a 'ping' on the address. If you don't know how to do that click on the Start button - go to run - click it and type cmd - then hit enter. That should bring up a black box. Then you would type ping - hit enter and see if you get a reply. If so that should be the right address. If you get a timeout then that is not the right address. Try different addresses then.
In addition to the other suggestions, also check to see that you have a common "workgroup" name for the computers and that the computers are in the same IP address group. (You don't want one computer with and another with a 192.168.0.* address, for example.)
got a firewall?

ya might have to physically go into it and select an IP range, or the specified device so the firewall will allow it to be seen by the pc.

after that you can try these:
open explorer and look for the NAS drive... find the folder within it which has the music files.

open one of the folders and right click onto it and choose 'open with' and select iTunes... if itunes is the only media player it should be listed and no need to pick open with, and simply pick play in itunes instead.

that should direct itunes to the drive.

if that isn't working... refer to my first note.

you can also connect the folder to your pc as a network folder. Then direct itunes to that now connected folder.

with my xp pro that's what I have to do to get things better... with xp home, I didn't have to. Vista didn't need such added measures as did xp pro... Pro has more security protocols in place. Vista just nags at you all the time until you disable the UAC... and setup defender better.

Also Vista has some out of the box issues at times with wireless connectivity... see my other Vista posts on the fix for that.

it's easy... even I can do it. it's just not terribly intuitive.
Thanks for these suggestions. I will certainly try all these.

Yes, the NAS path was a is

Thanks again
BTW, should have mentioned...Windows (XP Pro) does see the NAS. The NAS and its folders can be seen on My Network Places (which includes the iTunes and other files).

Also in Itunes Preferences Advanced iTunes Music Folder location, the NAS iTunes path is also shown, but as I said, iTunes would not accept the network path, and hangs up.

So it seems, Windows sees the NAS iTunes location, but iTunes does not.

Thanks again.
I would try browsing to the network location rather than inserting it. If it shows up in "my computer" then you should be able to browse to it. If it doesn't show up in "my computer" you need to figure out how to get it there. Perhaps you need to give it an alias which makes it look like any other drive?

Once iTunes sees it it still won't play the files until you add them. Naming a music folder in iTunes advanced preferences only tells it where to put files it adds in the future, not where they are now. To add them you can either use the iTunes menus or just drag and drop the file folders into the iTunes library.
I think Herman is onto it. You have identified the location to place music and where to look for music (to play), but now you have to run your search for music from iTunes to populate the music into iTunes.

As for Apple not supporting iTunes, this does not at all surprise me. Over the past 10 months my house has converted from PC to Apple - 4 laptops and 1 desktop. I called a couple of weeks ago because one of my batteries just died and found out via the internet that there was a problem and that Apple will replace the defective ones, even when out of warranty (which mine wasn't).

Apple technical support refused to even discuss anything with me until they could confirm my computer was under warranty (which I could not do during my first call). They would not respond to a single question, unless I was willing to give them a credit card number to charge me for asking a few questions about a defective product.

Overall, I have been completely unimpressed with Apple from a service perspective, though their operating system is light years ahead of MS.
The iTunes application in your new computer has not yet mapped its library (database) to your NAS drive (location). Try File/Add Folder to Library... and navigate to the folder in your NAS where all the music files reside.

When the mapping process is complete, go back to Edit/Preferences/Advanced/iTunes Music Folder Location > Change...and once again navigate to the same folder in your NAS (assuming it's the same folder you wish to add music files in the future).

Hope this helps.
I've yet to find a media player that is supported well by the ones behind it's issuance. For that matter I’ve found little erstwhile support from any PC apart from Dell, and they ain’t no picnic to deal with either. The only resources are the other users predominately, and that’s a sad story if you ask me. Even for those media players you are forced to purchase if you want the advanced feature set the upscale version offers, you simply can’t rely upon them.

It’s like, Pay me, have fun, hope it works for you.

To apple/iTunes credit they did help me one time. Couple years ago I had a drive fail and lost a significant amount of tracks I had purchased from them. Several thousand in fact. Some were no longer available, but following a few emails, one lady on the Apple support team enabled me to re-download all they had on file for me. That amounted to close to two thousand tracks. Whew! I was grateful for that and had the idea of buying more digital acreage for backing up burned into me once and for all.

One thing…. When experimenting with pointing to folders, importing, etc. Just do one folder … an album for instance… when first trying to get things situated. Wasting time to sit and watch itnes import files it won’t track back to or play outright is not helpful. Once one artist/album is successfully imported, THEN go get the balance of the library.

If the drive is mapped properly itunes will play it. If not mapped, firewalls, permissions and such need be setup right. XP Pro is mighty picky… way more than XP Home.

YOUR NAS DRIV E should have a setup menu wherein you can map a folder directly to the Pro pc… and it’ll be seen as another drive. Browse to whatever folder you seek to add to itunes that way. Wx. If the nas folder containing the music = tunes… and tunes shows up as tunes on nas Z: … look for that folder outright… and not in your workgroup.

BTW… that has to be done if some other media player is used to play itunes protected files… sometimes… and definitely on my xp pro box.

If you tick the Make itunes the default player box in Preffs, Windows Explorer will show it in the right click menu when browsing and playing files from there.

If a mistake is made just delete the *.itl file from the itunes folder in My Music, (default location) and start over. They should put a clear library option in the player, but have not yet. Deleting that file will also delete your playlists, but leave the files alone. Make sure too, not to tick the box saying copy files to the itunes library folder when importing or adding files. That is a problematic selection!