Innuos Zenith can't connect to my.innuos


Hi--

Just took my new Innuos Zenith Mk III out of the box and hooked it up to an ethernet
port on my router to my Win 10 desktop and can see it fine (including its empty file
folders, lol) but as soon as I try to go to my.innuos.com to begin fw d/l and setup, their
page says no Innuos server found.  I guess they can't see my i.p. address so I've tried
re-starting the Mk III, turning off my A/V, checking and turning off auto port routing and a
bunch of similar things but nothing works so they can see my device and I can finish
setting it up to actually use it, lol.

It's the middle of a weekend night in G.B. so not expecting much help from Innuos.  Not to mention
their "support" website is the most barren I've ever seen.  Only a copy of their Quick Start Guide, which
I already have, and a broken link (404 error) to their assumedly more in-depth user manual.  No FAQs, trouble-shooting
guides, user communities, etc.

Any input appreciated.
fasiya
I have had similar problems. See if the response pasted below from Innuos can help you
Thanks for reaching Innuos support.

The Zen you are connecting in the same conditions as your Mini, doesn't have the same IP address as the Mini. Your browser and apps are looking for a device at the address of the mini... You have to erase this memory...
Go in your browser settings and clear the History. Retype ''my.innuos.com'', do not accept and shortcut, bookmark or auto fill... You have to type it all. If both the Mini and the Zen are connected to your network, you should see them both. Alternatively, you can type ''\\zen\'' (Windows) or ''zen.local'' (Apple) in your Browser and you will find it. In Orange Squeeze, you have to reload the server.

Please let us know if you require any further assistance.

Thank you! Best regards.   Emmanuel Le Quere
Thanks guys--meant to answer sooner but went to a different
computer and didn't  have my sign-in info stored, lol.

Will post if I find anything.
I had the same issue. I was using Google Chrome and some of the extensions blocked Innous. When I used MS Edge, I had no problem.
B
Ha ha, this a complete fiasco.  vin998, "zenith" worked fine, thank you.
set everything up as I wanted and then clicked on configure
for Roon core. it did all that, gave me a success message.

went to Roon app on my desktop and it simply can't find the
Innuos as a Roon core and I can no longer see the Innuos
anywhere on my local network.  essentially bricked until
I can figure out how to do a factory reset or something.
gdnrbob3--

thanks for the input.  on Edge, it wanted me to ADD extensions,
which worked fine.  but like I said above, once i asked for
Roon  core integration and it finished can't see anything anywhere, lol.
http: zenith now says the Innuos is offline though I can see the
appropriate data lights on both end of the ethernet connection.