I need help with hum

Moved into a new apartment. Despite the Cinepro line conditioner I am getting a BRUTAL hum throughout the system. Problem persists even if I direct wire cd player through amps skiping all other components??? Is this a power problem? A Ground problem? Is there a cost effective solution?
Do a search on Audiogon for "ground loop" and "hum". Tons of material. Good luck.
Been reading old posts since I placed this one. Seems that i have that good old 60hz ground hum. Sound is worts through the sub woofer. I am going to try disconnecting everything else in the house tonight and running just my Carys and the cd player. One post cought my attention - I did hook up a digital cable box to the system. However, I thought - expected - that any problem like this would by solved by the Cinepro conditioner.

Open to any thoughts or ideas.

Line conditioners don't usually fix ground loops. At least that's my understanding.

In my system (and this is explained in detail in a recent post called "Ground Loop - New Twist?") the problem was that the cable installer had my cable entry grounded to a neighbor's electrical system (I'm in a "condo" of a sort). If the cable system is connected and the problem didn't exist before, that is, in all likelihood, the culprit. Look for info on CATV ground floaters like the Mondial Magic.
First step - disconnect the cable TV wire from everything and unplug that cable box.
I had a bad hum not too long ago. I have a tube amp connected to a TV. I got a 3 prong to 2 adapter which removed the ground from my amp. Bingo. I am using a surge protector.
I concurr with the above posts.
Going from 3 prong to 2 prong reduced hum from my turntable/MC/pre-preamp. Connecting cable TV via VCR caused terrible hum that disappeared when the cable was disconnected. I have heard of units that can block the cable hum but I have no experience with them.