How to do dedicated circuits with isolated grounds

I have reviewed manu of the threads in the archives, and if anything I am more confused.

Prior to meeting with our electrician (who likely has no appreciation for audiophile requests), I would love to get some accurate and safe advice as to what I should be asking for.

We have started early construction of a renovation that will include a dedicated audio room. Our 100+ year old home has had it's electrical work modernized years ago with a 200 amp service. Presently, I haven't explored what kind of ground is in place now. Soon we will need to start wiring for the third floor renovation. For the audio room, I was considering having 5 or 6 dedicated 20 amp circuits with isolated grounds. I was thinking that we could run a conduit from our main panel to a subpanel on the 3rd floor (3 floors above the main panel and about 50 feet behind the panel). I guess I would ask the electrical contractor to run the 5 or 6 dedicated circuits from the subpanel. I was thinking of going with 10/3 BX wire for these dedicated circuits and connecting them to PS Audio Power Ports receptacles. Now, my question is what is the electrician supposed to do to create isolated grounds using the 3rd conductor wire in the 10/3 wire. Could someone try to explain to me what is required. Do I need to create another earth ground ? How do I ensure that each dedicated circuit is truly isolated from the others ? Is it necessary for each line to be equal length ?

Could someone explain what is the dirty ground vs. the isolated ground ?

Is it advisable that the other electrical circuits for the 3rd floor (e.g. standard recepacles, lights, etc. run off a second subpanel, or is it OK to have them on the same subpanel as the dedicated circuits ? What about the electrical wiring for our heat pump on the 3rd floor for the 3rd floor HVAC ... any advice ?

Sorry for these questions, but I live in a small city with no recognized audiophile electrical contractors.
I did the same type of installation. From the main panel, I installed a 2-pole 100-amp breaker. From this breaker, a run of 1-inch EMT feeder to a 100-amp main-lug sub panel (check with your codes if your sub panel requires a main breaker). The feeder consists of two #3 phase wires, a #3 neutral and a #8 ground. The two phase wires were twisted to minimize common mode noise.

The 100-amp subpanel has a ground bar kit installed. From the sub panel 20-amp breakers, I ran one 10/3 wire to each outlet. The hot/neutral wiring to the outlet was conventional but the green ground wire was attached to the outlet ground screw. The outlet itself was isolated from the box by a plastic strip. (I used BX and metal boxes so I wanted to isolate the BX sheathe from the ground path.)
The nuetral wire from the outlet went to the neutral bar of the sub panel and the ground wire went to the ground bar. The grounds and neutrals are on their own bar - conventionally the G and N's would both go on the neutral bar.

The neutral bar in the subpanel is directly attached to the feeder neutral and the subpanel ground bar is directly attached to the feeder ground conductor - NOT to the bonding fittings. Back at the main panel, the feeder G and N are attached to the neutral bar (no ground bar there - old panel) but it does not matter because the "star" node of the ground is in the subpanel.

Again, check with codes. But my setup has not given me any headaches or hums.
I just rewired the power to my system also, but did it a little differently - I put in a 240V circuit. I added a new 200A sub-panel next to the main service panel, used a 15A 2-pole breaker, and then ran four 6awg wires (2 hots, 1 neutral & 1 ground) through 1" conduit to a 240V outlet at my audio equipment. There I used a Richard Gray SubStation to drop the voltage to 120V.

At the the new sub-panel I put new ground rods into the earth and connected them to an isolated ground bar in the sub-panel. This is a ground bar that stands off from the sub-panel on plastic insulators - it had to be purchased separately and installed. The ground wire from the outlet connects to this. Code here does not connect the neutral wire in a 240V circuit, so I ran the wire but did not connect it. If any other circuits go into the sub-panel in the future I will connect them to the existing ground - the new ground is strictly for the sound system.

This set-up has proved to be very quiet for me.
Post removed 
Post removed 
I have to agree with Jea48 that larger gauge wire is desired for good transient response (lower voltage drop under demand). I went with #6 wire because it was the largest gauge wire I could use that would minimize voltage drops and the need for terminal lugs. Since I was using 240VAC, #6 wire is equivalent to approximately #2 wire at 120VAC - I would have used larger wire if it was pratical.

If I could make a recommendation, look at Siemans circuit breakers. They will accept a larger gauge wire than many other breakers, without needing to add terminal lugs - terminal lugs are just one more unneeded connection. As a side note, I have isolated ground rods that are connected with #4 bare copper wire.

If you are going to stay with a 120VAC circuit then look closely at Jea48's response. Otherwise, a 240VAC circuit will give you IMO better common noise rejection, and a quieter circuit overall.

Also, I also agree with Jea48 to keep as many additional circuits off the audio circrit as possible, especially motor loads.

Hope this helps. Please ask questions, if you have any.