How do I connect my Bricasti M21 DAC to my MAC Computer using the Network (Ethernet)


How do I connect my Bricasti M21 DAC to my MAC Computer using its Ethernet connection?   I want to run QoBuz on my MAC Computer and send the QoBuz output to the Bricasti M21 DAC using the Ethernet connection.  I will set the M21 using the IN5 LAN and Network setting.   This means the M21 connects to my network.  

Can I use the Qobuz interface and/or do I need some other software running on my MAC for this to happen?  This is a temporary setup so a large expense for any needed software is not required.  

If I need a software package on my MAC, what software package do you recommend?      

Your advice is requested.  Thanks.  
hgeifman
Post removed 
@hgeifman- I have connected my Bricasti M12 to a Mac Mini server using the ethernet interface and this connection is very simple to set up. You would need a music player/organizer software like Audirvana/Roon/JRiver installed on the server which will handle all music files or the Qobuz connection in your case and send it to the player M21 over ethernet.
Once you install the music software on Mac computer, connect both the Mac computer and the Bricasti DAC M21 to the router using ethernet cable and complete a quick configuration on the music software you are ready to roll.
I use Audirvana because I like its performance on Mac better than the other two. As part of setting up the music software on Mac,
1. you have to select M21 as the player (the software would auto detect and list M21 as the DAC/player as soon as your M21 is connected to the network via ethernet cable) 
2. You have to connect to Qobuz using your account information
This will complete the entire set up process.
Hoe this helps.
@indranilsen, Thank your for that great information.  

Audirvana looks good.  I install it on my MAC Computer and set the Bricasti M21 DAC for IN5.   Is there a setting in Audirvana that outputs Qobuz to the M21?   Any other settings I need to know about?  

Can I use my iPad to connect to Audirvana on my MAC to select albums to play?   Thanks.....

@hgeifman- Yes you would be able to use any iPad to play your music through M21. You need to install Audirvana Remote on the iPad which will simply turn the iPad into an Audirvana remote.
In the Audirvana settings you will see a streaming section. When you open that you will see different streaming options like Qobuz, Tidal, etc. Select Qobuz and connect it with your user id and pwd. That will complete the Qobuz set up process (most likely) and you would be able to stream through Audirvana and play through M21.

Thanks.

 

@indranilsen, Perfect.  Thank you very much. 
I installed Audiovarana on my MAC Computer and set my Bricasti M21 DAC to IN5 meaning LAN connection.   This connection works since the lights are flashing.  My MAC Computer and the Bricasti M21 DAC are BOTH wired to my router and I have connectivity.      

I am UNABLE to get Audiovarana to recognize my Bricasti M21 DAC.  I re-booted the router and modem and turned off my MAC Computer.  I also turned off and restarted the Bricasti.    I talked Bricasti Customer Support and he said I am doing everything right.

Audiovarana should automatically recognize my Bricasti M21 DAC BUT it is not.  I must be missing a setting somewhere.  

What am I doing wrong?   Help.   Thanks.  
@hgeifman- Do you have a window or a router software installed on the Mac that shows all lan connections wired or wireless connected to your router? I use Netgear router and they have a software called Genie which shows me all lan connections, connected to my Netgear router. If you have something like that then the 1st step would be to verify whether Bricasti is listed there and has an IP address. You have to make sure that Bricasti M21 is available on your network and the above diagnostic steps will help verify that part. If you see M21 in the network list then first get the IP address. The next step would be to ping it by issuing a  command like ping IP Address. If it is ping-able then Audirvana will surely detect it....
Thanks.

Another item to check: On the Audiovarana window bottom right corner is a speaker icon. Click on it and see if the Bricasti is recognized. If it is make sure it is selected.
@welcher, Thanks.  I click on the Audiovarana window right corner on the speaker icon.  The Bricasti M21 DAC does not show.  The only thing that shows is the local connected DAC.  Should I be clicking someplace else?

Maybe my MAC and the Bricasti DAC are not on the same network.  So, I ran the LAN scanner and did not see the Bricasti M21 DAC listed but am unclear what it would show.   Any suggestions?  

Audiovarana should automatically recognize my Bricasti M21 DAC and it does not.   Are there any other settings on my MAC or on Audiovarana that are blocking the Bricasti DAC?    


When you run the LAN scanner you should see a host name and ip address for the bricasti and your mac. Both devices need to be on the same subnet. Is your router the wireless router provided by your network provider (ie Comcast, Verizon, Cox etc)? Try turning off wireless on the MAC; reboot the MAC and see if you can reach the Bricasti and the internet
@welcher, Thanks.  I am using a Luxul XWR3100.   My MAC Computer is wired to my router and so is my Bricasti M21 DAC.   I have spent all day on this and cannot get it to work.  

Based on info received, it seems the Bricasti M21 DAC is not being recognized and you may be right they need to be on the same subnet.   I will work on that on Thursday.   

I have rebooted all devices several times and still l nothing.   
Thanks for your help but I give up.  I spent the entire Wednesday working on this and was NOT able to get my Bricasti M21 DAC to connect to my Internet.   Next, I LOST ALL Internet connectivity AFTER I reset my router (as was suggested by someone, AND a huge mistake).  My ISP helped me get that fixed.   Next, my iPad would NOT connect to the Internet. I finally fixed that and then discovered my Aurender N10 would not connect to the Internet.  I powered down my N10 (unplug from the wall) and it connected perfectly when it restarted (Thank goodness).   Of course, my furnace/AC thermostat LOST its Internet connection so I had to restore that. 

I wanted to connect my Bricasti DAC to Audirvana as an experiment to see how it sounds using an Ethernet connection.   I talked to several people (Thanks for your advice) on Audiogon (and many others) and followed their suggestions.  Nothing worked!!! 

Based on my understanding, my Aurender N10 connects PERFECTLY to the Internet BUT when I move the EXACT same Ethernet cable to my Bricasti M21 DAC, my network refuses to recognize it.  My best guess is the IP Address thinks the device is the N10 but it is actually the M21 DAC.   To be honest, I really do not know or understand.  One suggestion was reboot my Luxul XWR3100 router and modem before I connected the Bricasti.  This also did not work.   

My home network is very simple and not complicated.  I have 2 MAC computers (wired), one iPad (wi-fi) , 2 iPhones (wi-fi), an Aurender N10 (wired) and a furnace/AC thermostat (wi-fi) that connects to a LUXUL switch box to my LUXUL XWR3100 router to my Arris modem.

I am not willing to spend any more time on this.   I do not understand why this is happening.  It absolutely should work.    

Thanks again for all your help.

HOWEVER, if someone has a simple solution that does NOT impact my Internet connectivity, I might be willing to give it one more try. 


Bricasti is a world class Company.

The Bricasti National Sales Manager CALLED me this morning and REPORTS Bricasti has seen this connectivity issue before. The SSD card in the unit is corrupted and they are sending me a new SSD card ASAP. Amazing.

IN ADDITION, one of the Bricasti retailers I was working with sent some info regarding my issues to Bricasti. They already knew and were working with the National Sales Manager on a solution. This is truly Outstanding customer service. This Bricasti retailer on the East Coast saw my post on Audiogon and was trying to help solve the issue.

Thanks to Bricasti and Steve from Sounds of Silence for all their help.
OP you are in good hands, Bricasti is a first rate company and Sounds Of Silence has also helped me in the past.
Keep us posted once all is resolved.

I installed the new SSD Card received from Bricasti and Audirvana still did NOT recognize my Bricasti M21 DAC.

Bricasti and I checked the lights (opened the case) on my Bricasti DAC and the lights on the internal LAN Card are flashing okay (meaning it is connecting okay). I installed MConnect on my iPad and it recognized the M21 DAC in 2 seconds. MConnect connected PERFECTLY to my M21 DAC AND plays perfectly thru my Bricasti M21 DAC. This shows the M21 is connected to my network. The iPad sends a Wi-Fi signal to my LUXUL router and the router is sending the signal to my DAC using the same Ethernet connection used for the Bricasti DAC

Is it possible the Audiovana trail version does not support the Bricasti DAC? OR, is there an issue with Audirvana not working with my Bricasti DAC?

I deleted Audirvana and reinstalled it. This also did not work.

In summary, I installed Audirvarana on my MAC Computer and set my Bricasti M21 DAC to IN5 meaning LAN connection. My MAC Computer and the Bricasti M21 DAC are BOTH wired to my LUXUL 3100 router and I have connectivity. I am UNABLE to get Audirvarana to recognize my Bricasti M21 DAC.

Am I missing a setting somewhere on the MAC? Is this an Audirvana issue, setting or something else? This Ethernet connection was previously used for an Apple MAC Book Pro and it connected perfectly to my network.

Does anyone have any suggestions? What else could be wrong with my configuration that is preventing Audirvana from connecting to my DAC? Thanks.

Okay, I agree it might be some stupid error I am making. What am I missing? Thanks.



@hgeifman- You have to ensure that Bricasti M21 is accessible from your MAC computer, else no software installed on that MAC will be able to connect to it. One way to do that would be to ping M21 from your MAC computer after getting the IP address of M21 from your Router's admin page. You would need to open a Terminal (found under Applications->Utilities folder) window on your MAC and issue the command ping IP Address. If you see a response like

64 bytes from 192.168.X.X: icmp_seq=1 ttl=64 time=0.533 ms (where 192.168.X.X is the IP address) on the Terminal then M21 is visible to your MAC and the problem is most likely with Audirvana...

Alternatively you can install Roon or JRiver software on your MAC and verify whether they are able to connect to M21.

W/o the confirmation that M21 is accessible from your MAC it would be difficult to isolate and troubleshoot the real issue.

Thanks.


@indranilsen, The Audirvana connection to my Bricasti DAC problem is SOLVED and it was something VERY simple. I searched and searched and FINLLY found something useful on the Internet that pointed me in the right direction.

The Firewall setting on my MAC Computer was set to block ALL incoming connections. This means Audirvanna was UNABLE to connect to and recognize my Bricasti M21 DAC. I unchecked the box, started Audirvana and it FOUND my Bricasti M21 DAC in 2 seconds.

I connected to QoBuz and my favorite album was playing through my stereo system perfectly. Great news. It works!!

I am not done. Next, I will install the Audirvana Remote on my iPad. Stay tuned.

Thanks again for your help, suggestions, etc. I appreciate the many comments, suggestions, etc from everyone above. Cheers.
Post removed 
@hgeifman- Congratulations!!! I am glad that you are finally out of this connectivity issue and you are able to enjoy the music. A good learning experience for all of us who use ethernet interface for DAC connectivity.
Thanks.
As I reported above, the Firewall setting on my MAC Computer was set to BLOCK ALL incoming connections.   This means Audirvanna was UNABLE to connect to and recognize my Bricasti M21 DAC.   I unchecked the box, started Audirvana and it FOUND my Bricasti M21 DAC in 2 seconds.  

HOWEVER, I now have serious security issues with my MAC Computer.  If I OPEN my MAC Computer Firewall to ENABLE Audirvana to connect to my DAC, it means my MAC security is compromised.   I am 'paranoid' about computer security AND it is better to be safe than sorry.   The protection of my computer data is much MORE important than an audio connection.

This means I will NOT be using Audirvana  and it has already been deleted from my MAC computer.   My MAC Firewall is set for top security.

I am now testing MConnect and it requires no Firewall changes.  It connects perfectly to my Bricasti M21 DAC.  
  
I do not understand why Audirvana requires me to compromise my MAC computer Firewall security and MConnect does not.   I also plan on looking an HQ Player and ROON sometime in the future (maybe).  

A special thanks to Bricasti and Steve from Sounds of Silence for all their help.   Thanks again to everyone who posted above.   I appreciate the many comments, suggestions, etc. from everyone.  Cheers. 


Well done!

This stuff can drive you crazy.

I don’t own a Bricasti but am thinking about the M3. AFAIK you can use the Linn Kazoo and Lumin apps on your iPad with your Bricasti. Both offer an elegant UI with Tidal, Qobuz, Spotify and TuneIn radio, etc. I currently use Linn as my digital front end. I also use Roon and tested the Lumin app. All work...
@photomax, Great suggestion.  Thanks. 

Please confirm I can install the Linn Kazoo App on my iPad and it will connect with my Bricasti DAC?   Do I also need Linn Kazoo software running on my Mac computer?  
There is a piece of software called Konfig that you might need on your Mac? This is a just a settings/preferences/handshake pane. You can then add the Kazoo app to your iPad. 
I have not tried this as I don’t own a Bricasti. A dealer did say you can do this though. 
The Linn App, Linn Kazoo app and the Lumin app are full apps with features. They are free. Roon should work for you as well but that costs money. 
Thanks.   As you suggested, I installed Linn Kazzo on my iPad and unable to connect to my Bricasti DAC or QoBuz.   I emailed Linn Products and ask them for help.  
Linn Products said "If the Bricasti M21 DAC is an Open home renderer then you will be able to use Kazoo to control it”.
The Bricasti M21 DAC is DLNA and UPnP computable so any software that accepts those protocols will work.

FYI:   OpenHome (aka UPnP with 'Linn extensions') and standard UPnP/DLNA are actually closely related (BUT incompatible) streaming technologies rather than 'formats'. The main difference is that with OpenHome it's the streamer (aka renderer) that owns the current playlist; whereas with standard UPnP/DLNA it's the controller (aka control point) that owns the current playlist.

This gives the OpenHome renderer the advantage of being autonomous with regards to playing the tracks in the playlist once playback has started. It means the OpenHome renderer can sort out gapless playback for itself, allow multiple OpenHome control points on the network to interact with it without any side effects and even continue to play the entire playlist with all associated OpenHome control points switched off.

Contrast that with the standard UPnP/DLNA renderer which is completely reliant on the standard UPnP/DLNA control point for playback. So, the UPnP/DLNA renderer requires the standard UPnP/DLNA control point to tell it what the next track is and where to fetch it from every time the next track needs to be played. This forces gapless playback support to be an interaction between both control point & renderer and restricts the number control points that can interact with the renderer at any one time to one (otherwise you can get strange playback side effects with the various control points competing with each other to gain control over the renderer).

MConnect works and I am currently using it.  I was curious to see what other connection options were out there.  Please note my main source is the Aurender N10 Server.   Sometimes I like to experiment with other technologies especially especially since the M21 supports an Ethernet connection.   Based on my research, I will continue to use MConnect. Thanks again for your help.  Take care.