Help with clicks and pops on PC audio

I have used a Squeezebox Touch wirelessly with good success playing files on my laptop at 16/44, but with too many dropouts for higher-res files to be usable. Recently tried to go from laptop to DAC via USB to experiment with hi-res files, using JRivers as my media player. Files play, but with clicks and pops similar to a dirty LP. This occurs whether I'm going straight to my W4S DAC1 or ADL Esprit, and changing USB cables does not help. I'm wondering if the JRivers player isn't set up correctly? I was reading the Audiophileo site and note that clicks and pops can occur if hardware buffering isn't correctly set, but I don't really understand that or know whether that might be a clue to my problem. Any suggestions would be appreciated.
I don't know that much about computer audio as I am just getting into it but I found this on Empirical Audio's site. " 4.Dedicate the Laptop to music playback if you are using USB. Using the computer for lots of other tasks can cause conflicts, increase latency and cause popping in the audio. "
Thanks, Pal. I don't know that much about computer audio, either, but I'll look into the Empirical Audio reference and maybe contact Steve there.
i began to notice some drop outs with my dac, i found in the driver, i could set the playback priority "critical" and buffer size which i believe i now have at 4096kb (4mb) and that seems to have cleared things up for me. i only noticed the drop-outs when i was playing hires downloads.

also, here's a great website to help you tweak your windows settings:

this link is for win7 but there's other OS's listed.
thanks for the tips. I have much to learn about this aspect
of the hobby. I will start with increasing the buffer.

What you are hearing might have something to do with a low latency setting. I understand you use JRiver and Audiophilleo. On JRiver, go to Tools>Options>Audio, and at the top you probably have the audio device set as Audiophilleo, which is fine. Below that you have device settings. Get in there and you will probably see a scroll bar that you can take to the leftmost position and it reads more skip resistant ( this is higher latency). Try setting it there, save, stop playback. Actually, go ahead and shut JRiver down, then restart and see if the clicks continue.

Generally speaking we want lower latency, but only up to the point you hear clicks.

I hope this helps
I increased the latency and the condition improved. Thanks for the tips. I'll report back if that doesn't fix the problem.