Help with Blusound Node 2i and Qobuz output

Hi Folks. I am hooking my stream from the Bluesound Node Node2i to my Schiit Gugnier Multibit DAC via a glass optical cable. Qobuz is my provider. 
The sound is excellent BUT The output signal is low. I have to crank the volume control on my Raganok 2 to almost full on to get a decent sound level with 90db Triangle Bro 2 speakers. Normally this soul be blasting me ut of my room.
I checked Qobuz and didn't find any control to increase output. 
Got any ideas? 

Did you check the volume settings in the bluesound app?

Go to settings > audio > output level 

Make sure "fixed" is checked
@rnrmf1971 . 
The Bluesound app sometimes acts on its' own and lowers the volume.
Why it does this, who knows?
I'd also call Schiit if the Bluesound app isn't the culprit.

I've never had that problem with the BluSound level fixed. Occasional prob with other players however.