Help w/ weird big-screen tuning issue?

I just purchased a used Sony KP-61HS10 61" RPTV. I also have a smaller, older Sony set. Last night, I was watching the ballgame on the small set, thought I'd fire up the new one, see how it looked. I hooked up the cable to the RPTV, picture looked great, I switched to the very same channel that I had been watching the ballgame on the small tv, and ballgame! In fact, instead of TNT, I got the Food Channel! Two tvs, same cable, no other electronics attached or involved. The "local" channels, 1-13 were identical on both sets, but beyond that, I had many more channels appearing on the small set than on the RPTV. Also, if this is any clue, the Food Channel (which appeared where TNT should have been) was a poor quality picture. Any idea what's going on? Thanks! Ben
Just does to show you why you should never buy a WIERD BIG SCREEN !!! Sorry Ben I couldn't resist. That is very odd indeed, perhaps an issue with the tuner?
Have you tried running the channel auto program on your big screen? Look in the set up menu. There are usually options for over the air broadcast, cable, etc, and an option to auto program the channels.

Bob R.
Check antenna switch - could be you were not on the cable feed, receiving a broadcast signal instead?

Theory number 2: RPTV tuner wasn't set up for your cable feed which might be off enough versus previous owner?

Theory Number 3: bad wiring.

Bob Wood
Hmmm...I have run the auto channel selection and it scanned through all the channels and didn't turn up the missing content, just confirmed what I found punching in channel numbers. I was definitely on the cable feed. Perhaps the tuner isn't wired or working properly.

Tonight a "tech" from our cable company is dropping in to analyze the situation and try to set things straight. I'll be very surprised if he or she does anything more than run the auto setup the same way I did.

Next, I'll have to drop in on a sony big-screen store, and try to find a salesperson or technician under the age of 25 who might give me an opinion...the kids seem to know all!

Thanks for your help, Ben
You should let us all know the outcome. I for one am curious.

Good luck Ben, hope it's nothing serious.
Are you using a digital box for each tv? If so, same model?
go to the menu and set the tuner for cable, not aff-air