Help needed recording vinyl to computer

I just got a new Rega P3 turntable with a Cambridge Audio 640P phono stage. The cartridge is a Dynavector 10x5. I like the sound of it, especially considering there is only about 8 hours on it and it's not fully broken it. However, I'm having a problem recording the audio to my computer.

I have the output of the phono stage plugged into my sound card - a M-Audio Audiophile 24/96 card. It's a great card. However, when recording the audio into Adobe Audition 2.0, I noticed the sound is off center in each channel. Adobe breaks the sound into 2 channels in the waveform, and they are balanced fine. However, it also splits the individual channels in half, giving each a center point in the channel. I noticed that in the left channel, the waveform is mostly above the center line, and in the right channel, the waveform is mostly below the center line.

When I plug a CD player into the sound card, I notice that the sound is perfectly centered in each channel. So I know it is not the sound card at fault. It seems to be either the phono stage or the cartridge (?).

If it's the phono stage, does anyone have any advice what I can do?

I'm very frustrated with this - I'm itching to start recording my vinyl, but don't want to do it if it's not recording right.

Any help would truly be appreciated. Thank you.
What happens when you switch RCA jacks, do the settings change from left to right according to channel swap?
Probably the respective left and right channels of the phono cartridge have a slightly different output level. This is quite common.

I can't believe there's not a way to balance the channels with the computer software, but you could always put the louder channel through a passive volume control (or the balance control of a good preamp) to balance the output before it goes into the computer...

I do archiving (originally intended for my car) often. The results are so good that the CD-R's also get played inside.

The setup I have is conveniently arranged with short cable lengths. I use a homebrew mc cart and the armleads go first to one of several dc step-up devices. From there it goes to the 'phono'input of my 'workhorse' pre-amp which is a Kenwood C1 Basic Stereo control amplifier, with MM selected.

From the pre-amp output, a high quality phono interconnect goes to an Edirol USB Audio Interface UA-1EX.

The output of this soundcard goes to a cheap Genius subwoofer with which I power 2 high quality mini monitors as I cannot stand the sound of computer speakers. The subwoofer part is turned to zero and only powers my speakers. The latter (subwoofer) also has an input for a wired remote which is very useful as I can control on/off and monitoring volume here as well. Magix Audio Cleaning Lab/10 is used as recording software. Recording volume can be set both on the pre-amp or on the Edirol device.

I've never had channel imbalance as the Magix screens allow many ways to view what happens during and after recording.

Hope this helps.

It's not a chennel balance issue - both channels are fairly level. It's the sound in each individual channel - the sound in each channel shows off center in the Audition waveform.

I've heard it was DC offset. The software allows for correction of this, and when it did a check for zero, it showed it was .035 off center. But when I ran the function, it did not seem to change the waveform at all.

Since the sound card worked fine with a CD input, I assume the problem is not in the sound card. How could I correct this issue?
I switched the left and right cables, and the problem changed in each channel. Does that rule out the sound card as the problem?
It definitely seems to be a DC offset problem, with the left channel having a positive offset, and the right channel a negative one. This DC offset is being generated by your phono stage. The first thing you should do is reset the zoom level in Audition (right click in the dB scale to the right and choose FULL ZOOM), in order to make sure the recording scale is at the absolute center. Then try this:

1) The phono stage may need to be loaded with a lower impedance (10 Kohms to 50 Kohms), because the sound card presents too high an input impedance (100 Kohms or more). In this case try to connect a 22 Kohm resistor in parallel with every output channel at the phono stage. You will need a couple of Y connectors and a bit of creativity. Make sure you don't accidentally short the preamp's outputs to ground.

2) If the former procedure doesn't work, insert an electrolytic capacitor of 10 uF or so in series with each phono stage output terminal (keep all grounds together). This should block any DC in the phono stage, and allow you to record the signal. Observe its balance in the recording display. They should both now be centered at around -infinite.

It's much better to eliminate any DC offset before entering the sound card, in order to have a clean recording. If you wish, you can eliminate any remaining trace of it using the Constant Amplification effect at 0 dB, and enabling the DC offset compensation. Once you get a decent recording, it's time to begin looking for better coupling capacitors or a better phono stage.