Help mapping input on Theta Casa Nova

I am adding a CD player to my system which uses Theta Casa Nova as Pre/Pro and for the life of me I can not map Toslink 1 to the CD input, thus I get no sound. I have read and reread the manual but I am lost. I do not have the video card installed and this makes it even more difficult to see and program.

Thank you, Henry
From page 30 of the Owner's Manual:
To map input jacks, first press the Input Select Button (CD in your case.). Then press Setup, INP, A-D,then source. You can prioritize the order of jacks you map to your input. Button #1 is the first priority, Button #2 the second, etc. Use the level up-down button(top and bottom pie buttons)to select the appropriate jack. You can map up to 6 jacks to your input. Press Setup to exit.
Thank you Jimburger, I have read and reread a dozen times but I am still missing something. If you have a Casa Nova would you be willing to walk me through it? If so send me an email and I will call.

Thank you,
It's possible that your speaker settings, crossovers & etc. arn't set up as "Global". If that's the case, you've got to individually go through the Setup menus with the Imput Select button set to your CD, and the A/D button set to the Toslink Jack (Setup/Global/Jack Names).

If that doesn't work, E-mail me with your phone number and I'll try to talk you throught the process.
Thanks Raks, I will try that first and if no luck shoot you my phone#.

Thank you, Henry
Still not working, the unit is set to global. I will email you my number.

Thank you,