Help: Low output on one channel

I have something weird going on with my Peachtree Nova integrated amp. The output from one speaker (left) seems to be lower than the other. Here's what I've tried and what resulted.

I tried swapping the RCA cables from my Mytek Brooklyn DAC+ to the Peachtree AUX inputs so the left went to the right and the right to the left. Nothing changed. I tried moving the RCA cables from AUX 1 to AUX 2 on the Peachtree and nothing changed. I tried swapping the left and right speakers and nothing changed. I tried swapping the left and right speaker cables and it reversed the imbalance. I then took out the cable with the low output and replaced it with another cable that I know works and nothing changed. At this point, I suspect there's something wrong with the left speaker terminal in the Peachtree but I thought I'd ask the audiophile community for any advice.

Any thoughts?

Any diff if you switch between tube & SS circuit?      On a different tack: How old is the Peachtree?      In the past; I’ve had to replace those wimpy, surface-mount capacitors, in digital components (preamps with ADC/DAC boards) with the same symptom.
Hi, thanks Rodman. I went to go try this but before I did, I decided to take the DAC out of the chain first and run the system solely through the Peachtree. I have a Halide Design Bridge USB/SPDIF converter that was running from my Mac Mini to the DAC, even though I wasn't using it. I've been using exclusively the USB cable from the MAC to the Mytek, but still, the Bridge was in there not being used. I disconnected it from the Mytek and ran it to the coaxial connection in the Peachtree and lo and behold, the left and right channels were balanced with the sound coming out of the Peachtree's coaxial input. Then, I switched back to the Mytek, which was still connected to the Peachtree's AUX RCA input and now left and right channels are balanced coming out of the Mytek too. And, just to try it out, I ran it with the Peachtree's Tube buffer on and that also works fine. So for some odd reason, the problem is solved and it seems to have been the presence of the Halide USB/SPDIF converted being connected to the Mytek. I have no idea why this would be the case but as long as it seems to be working, fine, I guess.
The less complex a system: the better the performance, as a rule (at least, in my experience).      Isn't it great, when you can figure things out on your own?      KUDOS and happy listening!