HAs PureMusic changed their Algorithm

So, I have been a huge proponent of PM for about 4 plus years now. I love their licensing and the updates. Up until this latest update, it has always been a slight bug fix or a new feature (like the DSD playback) but the one thing I could always count on was the sound. The sound was always the same or maybe tweaked ever so slightly for the better. Imagine my surprise when I installed the latest version of the software and the whole thing collapsed (sound-wise that is). I mean it lost that magic (think of that inner lit magic of a superlative 300B SE) and kinda moved to a more modern dac sound. The sound was very Crystalline and VERY resolving with ABSOLUTELY NO WARMTH OR EMOTION. I went back and forth with the previous version (I think 1.88a) and their was simply no contest.

As a result I have not upgraded and continue to run the previous version of the software.

I have used PM with my former Bidat/MSB PowerDac/Ayon CD5S (did not own the Ayon)/Metrum Octave + Diverter HR/PS Audio PW Dac (did not own this unit)/ and my current reference the AMR DP 777.

PM suggested that I have a 3rd party switch it so I would not expect the outcome.... WAIT..,WHAT? First off I know what I hear, I am not one of those audiophiles that needs another person to TELL me what I am hearing. Secondly, I have gone through about 7 or 8 upgrades since I purchased the software and this type of drastic change in sound has never occurred and lastly my own comparisons over 4 iterations CLEARLY told my ears that something different and not so good has taken place.

I can not prove it but I hypothesize that they tweaked their audio engine and IMHO.., not for the better. I want to hear from others if they have experienced the same thing.
I agree. The sound is brighter. But what is bothering me much more is how buggy PM has become. I'm having to restart it often because it will suddenly stop playing music. Hogg mode is totally non-functional. I keep hoping the soon to be released vs. 1.9 will fix all this.