grounding issue

i am having some major hum with my jolida 302 b. when i have my phono hooked up there is no hum, but when i try to hook up my DVD/SACD/CD player i get terrible hum. however if i plug my ipod into the same connection via RCAs i get no hum. i am wondering if i am not grounding the DVD player properly. actually its not grounded at all i dont think. my system is a MMF 2.1 into a bellari 129 into the jolardi 302b. the dvd player is plugged directly into the jolardi with relatively high end cables. like i said the ipod plugged into the same input with terribly cheap RCAs makes no hum. thoughts?
Do you have cable or satellite TV? If so, try disconnecting the coax cable connecting the cable/satellite to your TV/system. This is a very common cause of a ground loop which produces a hum.

If this fixes the problem, you can put an isolator on the cable and it will resolve the problem.



Two thoughts

1. Try plugging into a different outlet if possible...especially one not on the same run to your elctrical pannel.

2. I had to remove the ground plug on my CD player in order to eliminate hum...I ended up buying PS Audio power cables and unscrewing the grounding pin. That solved the problem for me.

Just some thoughts that may or may not apply.
i disconnected the HDMI cable from the SACD/DVD and the issue was solved!

thanks AGON!
I have the same problem with buzz, though it only effects the left channel of my stereo system for some reason. This seems to be a relatively common problem with various work arounds like not using the HDMI output of the HD-DVR or bypassing the electical ground. What I can't figure out is why that is so. Time Warner here in San Diego doesn't seem too concerned that their cable system is causing the problem - which makes me wonder it AT&T uVerse could do a better job.