gemstone owners, any problems thus far?

I am also wondering How much power there is with all 7 channels driving 4 ohm speakers. I have compared this amp to monarchy audio monoblocks and 4 people picked the gemstone. Same results when comparing to the original Cinepro 3K6. They were double blind test. Any suggestions on amps to try to dethrone this amp? I would not ask but My amp shuts down at reference levels so Steve and I are trying to figure it out. Just in case we can't any contenders? Please no super expensive stuff, the gemstone cost $2799 and beat out $8400 worth of 7 monoblocks.
The Gemstone Blue Diamond is a nice unit that I had and returned for a variety of reasons. The journey ended with a Theta Dreadnaught (200 watt modules), and I haven't had an itch to switch to any other multichannel amp I've heard. A second-hand Theta is price competitive with the Gemstone. Ayre and Innersound (or similar Coda) amplifiers also merit strong consideration, although several units may be required depending on your system configuration. Go with a phantom center and a pair of Ayre V-5x/V-3 or Innersound ESL-300 stereo amps and stand back. Good luck!
I am leaving the amp on and noticed that reference level has dropped 2 db's. What I mean my reference setting on my preamp used to be 80 and now it is 78 to hit the same 105 db's and 115 db's for the sub. My amp has not shut down on the 78 setting. Awesome sound, I can play 105 db's in stereo with no problem. I will probably keep it if it does not shut down at this level.
I have a gemstone 7 ch amp and It beat out (to me) amps over twice the price easily. Not 1 problem with it (have had it over 1 year) and I really like it ALOT!!! I use it with B&W 803D's for stereo and a 5.1 ch set up for surround. I Bi-wire the 803's with the Gemstone and single wired to center and surrounds. I reccommend it very highly and Steve (who sells them) is the best!
I have a gemstone blue diamond 7 channel amp.. Had it for about two years. Just this evening the blue power light started blinking on power on.. I disconnected inputs and outputs methodically with the same result. The amp needs repair.. I went to the gemstone audio website and it appears they are out of business.. Any suggestions where can get the amp repaired? Thanks in advance.
Try contacting Steve Herrela at Sound Video of Minnesota for advice.
I also have a Blue Diamond with a blinking blue light on start up. It has been an awesome amp for over 4 years - the best I have had and I have owned Krell, Counterpoint, Legacy, etc. Steve responded once but now no communication. Can't live without my system so I just ordered an Outlaw 7900. Now trying to figure out how to get two 15 amp circuits up to my great room and then how to deal with really ticked off neighbors...