Gamut L5 fried speakers


Dear friends,

I had trouble with my Accuphase Pre and Krell amp with 110 and 220V mixed, it ended up frying my right channel and I discovered it killed the drivers of my Gamut L5 speakers.

[IMG]http://img.photobucket.com/albums/v608/gabriel_37/IMG_0977.jpg[/IMG]

I'll write to Gamut Monday but as I bought the speakers in the US and live in Brazil the distributor will no help me and supply new drivers

Does anybody know where to buy a new pair, or better four new ones (thought of replacing the left channel too)?

Thank you very much for the help

Best, gabriel
gabriel_37
hi,
i have a pair of seas t18re/xfctv2 these are coaxial 18cm drivers. used in many high end speaker lines. i use it on my ascendo c7.. the extra pair i have i bought from ascendo last month as a backup, but i need to selll them.. if you want them , ill sell them to you for 175.00,,plus shipping. look them up on the web
try scan speak directly
Syhilly,

Thanks for you inputs, but I believe the speakers are quite different, those in te L-5 have radial stripes in the cone.

thanks


Dear G_m_c,

Ill try Scan-Speak directly. Thanks,

Best,
MY FRIEND I AM BRAZILIAN AND AI LIVE IN THE USA RIGTH NOW .THERE IS A COMPANY THAT SELS SCANSPEAK DRIVERS .THE SAME OF YOU GAMUT L5 .MADISOUND.COM
Gabriel,

I know this is quite an old thread, but did you ever manage to get the correct replacement drivers for your gamut l5 speakers. I need replacements as well but have not had any reply trying to contact gamut directly.