Fried Need Help ASAP - system is smoking

Everyone, I just got a call from a friend who is having major trouble with his system. He informed me that last night he got a small but annoying shock from the jack of his antenna lead on his HDTV box. He also noticed that when changing interconnects, he SAW electricity arcing between the RCA and the interconnect.

Today his system started smoking and he shut it down.
He said smoke was coming from the wires...

Upon inspection, he noticed a pair of interconnects which WERE both covered in a yellow/gold colored mesh when new (a few days ago) now one of them is a brown color - and hot - seems current might have been flowing in reverse or through both cables?.

I have a number of ideas as to why this might occur but I am hoping some of you can provide pointers or places to look for problems that could have caused such a problem.

it sounds like the system is not grounded. is there a ground fault in the wall power? get a polarity tester and check.
i do not think line level signals are high enough to cause such a problem.
it's a shot in the dark, i am not an electronics expert. good luck and happy new year!
Bwhite - have you used a multi meter to check the ground of the given outlet? Bizzare but occasionally true that the ground actually has current running through it. ...In some cases could actually be considered 'hot'.

You guys are awesome! Thanks for the pointers! That was the problem. Somehow the outlet itself was screwed up - and no, nothing is grounded in his system.

An electrician is now on the way!