Feeding my system 4 Adcom 555's & 1 GFA-545

I am new to posting to Audiogon, but have bought/sold equipment here before.
I am looking to power my home theater system which is a follows.
1 Yamaha RX-V992 receiver for my pre-amp.
1 Adcom GFA-555 for right front speaker 4 ohm Mono 850 Watts
1 Adcom GFA-555 for left front speaker 4 ohm Mono 850 Watts
1 Adcom GFA-555II for the 2 center channels speaker 4 ohm Stereo 325 Watts each
1 Adcom GFA-555II for the 2 subs 8 ohm ea Mono 400 (not 100% sure on this #)Watts
1 Adcom GFA-545 for 2 rear surrounds 4 ohm stereo 150 Watts

For a GRAND Total of 3,050 watts.
Can you see I believe in LOTS of head room!

My concern is that with this many Amps (5) on (ONE) outlet will be too much current draw and will cause problems, or at least make sure the amps are not under powered. I was running (3) 555's and a GFA-2535 with no problem but am adding a 555II and 545 and taking out the 2535. Currently the Living room is being remodeled so now is the time to change/add some wiring. I am looking for some recommendations, but not a pair of "tweak" cables that are $4,000.00, I don't have that kind of budget. FYI the outlet is about 40 ft from the breaker box (about 50 total with wall runs)and am planning on running new cable/wire form the breaker box if that will help. Everything has been plugged into a Monster Cable HTS1000 power/surge protector (I have the original power supply but could not find specs on it, so here is the latest model) http://www.monstercable.com/productdisplay.asp?pin=4445 .
I still can't figure out when we are using our home theater system the lights in the neighborhood go dark! :-)


Mark AKA Bullet100t
If it can be managed without too much trouble, run at least one dedicated line for your audio system. Two would be better, one for the audio, and one for the video. I ran one line, 10 gauge wire on a 20 amp breaker, that feeds two outlets. The outlet that has the bulk of the AV system has a PS Audio Soloist in-wall outlet. I have two amps on that circuit, a 300wpc Aragon two-channel, and an Adcom GFA 7400 5X100wpc amp, along with the bulk of the video, and some of the digital in that outlet. The remainder of the digital and the analog system is plugged into the other outlet, with a PS Audio Power Plant300 plugged into that. This has worked out well for me, but I think another dedicated circuit would be better.
This is a very inexpensive upgrade, and since you are involved in a remodel anyway, well worth the trouble and modest cost, especially if you can manage it yourself. By any means, now is the perfect time to get it done, you won't regret it, it's well worth it.

Best of luck,
Well, consider that a standard 15 Amp line delivers 1,800 Waats.......

You will of course do better with adding some dedicated lines. How many is up to you, I ran five 20A and two 15A lines when I did my power for the HT as I figured I would make sure to have enough, it was overkill, but I tend to do that!
I was wondering if anyone else has any recommendations.