Fatal error

Yesterday I came across the fatal error that would prevent me to access databases from the console. I've started calling tech support and figured out that input stream pops up with invisible character(s) that need to be cleared after an input of Data Base ID before pressing an Enter key.

It was invisible bug -- a Ghost In The Machine.




Sounds like the input line was padded with "blank space" characters (when first displayed) instead of "null" characters. There's a difference.

Usually if the input is padded with blanks, no issues. Null characters might be, but there are more than just blanks and null characters that might not be visible so blanking them out blindly worked even having the fact that there's somewhere in the input stream one or few invisible ones are "hiding".


I don't know what language is being used. Could be a initialization issue, boundry issue, etc.

Whew.  What a relief.

From the title "fatal error" thought you had sold off your wife's Lexus convertible and bought yourself a pair of 150 pound monoblocks.

Let us know if you inadvertently gain access to the Epstein island visitor list. That would explain a prolonged absence from the forums. 😉


Are you sure you're OK? Have you taken too much and need professional attention?

Let me know. Otherwise probably it's definitely IQ deficiency that isn't curable.


What database? What console?

They're not invisible...they're just unprintable so appear as blanks (which they are not).  



@barts Cognos DB platform

the window where you punch-in DB ID was indeed corrupt as if you would never see anything there even with PCR microscope.

normally it shouldn’t be any issue punching in any DB ID, but in this case there was a ghost character in the window preventing accessing DB due to unwanted and invisible character(s).

Are you trying to explain what visible what not to IT veteran with 30 years behind or what son? First you really need to know what is Ghost In The Machine before we even continue


Not trying to explain anything to you, I thought it humorous that you posted a thread about a DB error, that's all!  

I too worked in IT for many decades, now retired.  I applaud you for 30 yrs, I know how difficult it can be.

First thing I programmed was on a PDP-11 by hand in binary.  Long time ago.



Is this still the Audiogon forum?  Thought I'd died and gone to PC Mag hell for a minute or two.

Can someone please explain to me in very simple terms just what the heck this thread is about? I thought I was reading the Voynich manuscript!

Post removed 

Don't worry.  No-one got killed, even though though there have been a few punching-ins.

Post removed 
More to discover