Excited computer chip??

I love my Audio Aero Prima cdp. Have had it about 2 months--everything is cool. One day I have to make a couple of moves and when I replug the cdp, I hear the transport, (I believe it's the transport) go click, click, clicking. Stops on it's own. Don't think anything of it. Maybe just a surge of electric going back into this baby. Who knows? Anyway, I come home from work one day, (several days later) and lo and behold, this baby is doing this again. The cdp is always on the standby mode, which is AA recomended. Now when I press the on button, which fires this baby up, (with the display lit) the clicking stops. Freaks me out, how this goes on by itself AND the transport running with no cd in the draw? The cdp player has its' own dedicated outlet plugged into a Audio Magic Mini Digital. I call the guy I bought my AA from, and he (after speaking to some AA techs)tells me to leave the cdp player off (shut off from the back-not un standby) overnight. He said it just could be the computer chip that runs the transport. It may be static or something that's over excited it. Kind of, like, rebooting a computer. Anyway, it's only been two days but no reocurrence. He, said, quite ingenuously, thank god, if it happens again, he'll send me a new one. He feels, very strongly, that it won't happen again. Anyone ever have a cdp fire up or do any weird things because of a wild chip? I hoped I explained this adequately. Thanks in advance my fellow audiophools. peace, warren
It doesn't sound like anything bad. I've seen players do weird things after brief hydro interruptions, or after having their plugs hit slightly, momentarily disconnecting them.
Even when a player is in stand-by, it's still "on" and powered-up; only the display is off. A brief power outage or surge could cause the laser to try and read a disc that is not in the player, so it goes into a fit bouncing up and down until you turn it off. If it's a top-loading CD player or if the cover is off you can actually see it happening.
It sounds like you have a good dealer, and you have told him about it, so you should be okay.
Golden ears, that is certainly good to know. Maybe it is just that. The electric in the neighborhood could have had some surges. Who knows? BTW, I also called Audio Aero, and they don't have a clue, but they said, of course, that they'd take care of it if it happens again. They said the Prima is built like a brick shit house. Well, they didn't say it that way. They haven't had anybody report what I told them about. Problems don't go away, so it'll happen again, if I have a funky player. Will keep you posted. Please don't let me stop any other audiophools from chiming in. Obviously, by the lack of responses, nobody really has a clue. peace, warren
Warren - any more problems with your Prima? I'm looking into a new cdp, so I'm curious about the reliability or any chip/softawre upgrades for the Prima.

I shut the Prima off overnight. Has never happened again. That's 4 months ago. Hasn't skipped a beat, since. Perfection. I'm still in heaven. A $2200 player that sounds like $5K+ Amazing.