Electrical issues with Philips GA 212 Electronic


Hello all -
trying to get an old 212 to function. Replaced all the light bulbs, main switch is sound. TT starts as normal with the use of the touch panel, but stops as soon as the finger leaves the panels (33 or 45). The photo cell looks normal. I've tried to shortcut the photo cell circuit to see if the problem originates here, but with no luck. Any ideas what's causing the TT's unwillingness to work?
F02cc62e 0868 42c5 be2c f8270baee4edgeirbirk
I had one back in the day and learned that this unit must have the correct light bulbs to function properly.

At the time the correct bulb were not easy to come by. Similar bulbs from Radio shack did not work.

But if they do not draw the correct current, the TT will not operate properly.

Similar bulbs with the correct voltage rating and otherwise fit but the wrong current will not work. I no longer remember what the correct current is. Sorry.

Ken


Ken's comments above are exactly spot on. I think you might have some success retrofitting an LED for the job- that way you can set the current (by bypassing the LED with a resistor) such that the unit will work without your finger on the sensor.
back in the day i wanted this TT so very much. When I was about 22 I had a chance to buy one for $25 but it got snapped up before I decided to buy it.

I eventually bought one about 15 years ago. By then I already had an LP12, and came away from the 212 underwhelmed. Similar vintage Thorens tables were much simpler and worked better. Better arm, better suspension. 

But I admire someone wanting to make a 212 work. super cool table