DVD Player.....I am stumped.....

I just bought a cheap Samsung DVD/SACD for the video conversion, and to try new audio formats, I initially hooked it up as digital coax.

Sorry this model is HD841

Anyway, I got this real weird digital chirp sound, so I took the unit back, it would play for a bit and kick on, and sometimes it gave the chirp right away.
So I traded it in, got a new one home and same thing, so I switched coax input on Rotel pro, same thing, so again I switched, this time to Digital Tosslinnk and same thing, Now I have had 5-10 DVD Players, hell way back I had 2 laser disk players...and Never had a problem, it is not my Pro..because my Sony was fine before...I check and triple checked all settings on both DVD and Rotel...and I cant for the life of me found anywhere where I am at fault..so anyway I am stumped, please help! thanks Chad
Is the sound coming from the speakers or the Samsung transport?

I ask because we just built a new Win machine from New Egg parts and the LG DVD transport makes mechanical "chirping" sounds.
My Sony DVP-NS775V chirps (quietly) when loading discs. The chirp accompanies the player's reading in and determining the format (CD/DVD/SACD) of the disc to play. However, the chirp goes away during playback.
Did you set it's outputs to bitstream? Is the chirp DD and DTS or only DTS? Also, you do know that SACD is only analog output don't you?

Sorry if my questions are somewhat simple...but thats a lot of bad dvd players.

I set it up as bitstream, no pcm downsampling, my rotel reads to 192K , no compression, this was not a DTS movie, but when I was still thinkin I could fix it, I turned it off to be safe, Samsung never heard of it (ofcourse) and I am screwed because I bought it at SEARS so they service all their own sales, how can I be so unlucky to get 2 players doin the same thing, it seems to me and I should triple verify this, that when it is output through Multi channel bypass it doesnt do this...all the same it should work fine for Digital right? Thanks for the headsup on SACD, but I did know that, but I always post the little stupid things when I try to help too! I just dunno, after 2 units and 3 diffrent variations up hookups, and looking at the same 2 pages that Samsung so graciously printed for audio options and trouble shooting I am frustrated thanks all keep ideas commin who knows maybe I am doin something wrong....part of me wish I was atleast it would be working!
I picked up the Samsung to try out SACD without blowing alot of money. Also had some strange sounds (not chirps but close). I upgraded the cabling (Audioquest 5 cable set for SACD and the "best" Monster component video and digital cable since my son works at Best Buy - you wouldn't believe the discount on Monster products). The sounds went away. Spent alot of time with settings on the DVD and Outlaw prepro. Also, be careful with the jacks on the back - they are extremely flimsy.
Thanks but I am still lost.