Direct TV and digital hum problems

I hooked up a digital 5.1 reciever for a non audio bud tonight I donated to him. When I hooked up his Sat box via Roslink I got a high pitch faint but annoying hum thry speakers. I figured I would try dig coax and same result. I lastly hooked it up for Pro logic and no hum but its not digital as I had hoped to give him.
I lifted the ground, checked the ground at the junction amp in basement and all settings were verified.
I am by no means new at this, I have over $50k in my home theater and have done surround for over 15yrs all along being a DIY installer (I am also the nerd everyone calls for help.........and am pretty good at it too :)
My point is that I have tons of experience and just cant figure this out, hope some ideas come my way..........thanks all!
ground loop thru cable co-ax? Try ground isolation transformer on the co-ax. A good trial is to put two of those 300 ohm to 75 x-formers back to back. co-ax to 75 ohm to 300 ohm to 300 ohm to 75 ohm to co-ax.
I got a high pitch faint but annoying hum thry speakers.

I don't think the problem is a earthed ground loop problem.A 60 hertz ground loop hum is not high pitched. It is a 60Hz low level hum.

Is it possible you are getting a feedback loop somehow?
Is this the only digital input being used on his pre/pro.
If it is try a digital connect to his CDP, it may be his Pre/Pro. One other thought is phone line, did you hook up the phone line as DTV so loves us to do. Disconnect it and see what happens, but my first thought is the Pre/pro is generating a hum withing the digital to analog circuitry.
Not an expert here just have had DTC for about 12 yrs and this is a thought of something to try.
That phone line is a awesonme idea, if it isnt that then I am stumped. I will try that when I get back over to his house this weekend. Thanks for the idea!
Any way to move the equipment a few feet to the left or right. Tricky one since you lifted the ground.

As the years have passed we now have wireless routers , wire phones etc, wonder if it might just be in the path of a related or non related wireless signal.
The phone line didnt work, I wonder if its the way he has it stacked, on top of guitar amps and such (everything is in one big stack) could that be an issue?
He isnt an audio guy so I cant blame him but I would like to give my friend a little better sound. Thanks

Did you start from scratch? Just the SAT receiver box, toslink from the SAT box to the 5.1 receiver. Nothing else connected to the 5.1 receiver except the speakers. Nothing connected to the SAT box other than the incoming SAT coax cable and outgoing toslink cable. Even have the TV turned off. In fact unplug the TV from the power outlet. Just check the sound first do not worry about the video.

If no high pitch hum hook up one piece of equipment at a time. Maybe start with the TV video first.
Call the sat company and tell them about it.
They will come out and fix it free.
Its their problem their equipment, not yours.
I like to dispatch them on a regular basis, seeing that they raise their prices on a regular basis!
This happens often with Direct TV. The service has not been properly grounded. Call them back to fix it.
Did you try using an inexpensive hum buster?