DEQX not discoverable...


Hello all,

I had a DEQXpert do my initial setup/config.  In Apple's infinite wisdom, one of their updates corrupted my Virtual Machine and entire apple file system.  When I reverted back, my VM was corrupted.  I was able to recover the VM, but my install of VMware Fusion needed a fresh install and new license.  I'm up and running, but now my DEQX is not discoverable.  I updated my "gulp" Windows 7 VM, it rarely hits the internet and is quite stable, so I continued to use it just for my DEQX.  I've run thru the install wizard, reinstalled the driver and DEQX program, but it's still not discoverable.  I've used 2 different USB cables, still the same.  The debug window does 5 "LINK_INT" calls then "TRASH", repeatedly.  I poked around on the DEQX website and wasn't able to find any OS support.  My only thought is that Windows 7 is no longer supported by the DEQX wizard, though with the version I'm using it was working with the last update having been applied to my W7 box in 2013.  With the updates, it's still not discoverable, so I don't know if that would be the issue.

Anyone have thoughts? 
toddcowles
Sorry to hear that you are experiencing these troubles, Todd.

If I understand correctly you are saying that the DEQX Cal program cannot see the DEQX, when the computer is connected to the "USB control" connector on the DEQX. (As opposed to not being able to send music to the DEQX via the DEQX’s "USB audio" connector, if your unit has a USB audio interface).

If so, the only suggestion I can think of is to uninstall the existing installation of the DEQX software, and then installing the latest version of DEQX Cal (3.02.02) by running its .exe installation file in Windows 7 compatibility mode. As you probably realize, that can be accomplished by right-clicking on the installation file’s icon, selecting the compatibility tab, putting a checkmark in the "compatibility mode" box, and selecting Windows 7 beneath that.

And if that doesn’t help then try running the installed program in Windows 7 compatibility mode, which can be accomplished by right-clicking on its icon that is probably on the Windows 7 desktop screen within your VM, and proceeding as above.

Good luck. Best regards,
-- Al
KISS...

Keep It Simple Stupid...

Had the USB plugged into the audio and not the control port.  It's up and running.
LOL!  Well, that kind of thing happens to the best of us.

Regards,
-- Al
Al,

Is the latest firmware V201.58.12 ?

ozzy
Hi Ozzy,

No, for your PreMate it’s 201.62, as can be seen on the Support page of the website. (For my HDP-5 it is 201.61; I did that update a while back and it went very smoothly). A pdf providing instructions for performing the update can also be found on the Support page.

If you need the login information to download the firmware file you can contact Alan Langford at DEQX, or submit an inquiry via the website.

Best regards,
-- Al
@almarg Though I appreciate the thoughtful response, it's equivalent to me not putting lugnuts back on a tire; which has never happened, but there may come a day!
Thanks Al,

I was able to download the new firmware. What exactly does the new firmware do? Everything seems to sound the same.

ozzy
Hi Ozzy,

I've never seen any meaningful info on the purpose(s) of the firmware upgrade, and I too didn't perceive any sonic differences when I did the upgrade.  Just guessing, but perhaps one purpose had to do with optimizing compatibility with the most recent version of the calibration software, which in turn might have been updated to optimize compatibility with Windows 10, among other possible reasons.

There was also a separate upgrade to the display processor firmware that is used by my HDP-5 and the PreMate+ to control the touchscreen that is provided on those models.  That upgrade provided some enhancements to the touchscreen and I believe also enabled the ethernet interface and "Roon readiness" that are provided on those models.  (I don't use those features, btw).  But those things aren't relevant to your PreMate.

Best regards,
-- Al
 
Todd...I've done the same thing with my DEQX and the two USB ports...panic, then private embarrassment, then gratitude that it was my error and not something major. Wanted you know you are not alone.
Regards

More to discover