Constant noisy tubes maybe go solid state?


I have a Quicksilver Line Stage Preamp (12AT7) mated to an Odyssey Khartago Stereo. Overall I like it. Way too much gain but I digress. Weeks after receiving it I rolled in a few different tubes, kinda fun to color the sound signature. I liked rhe RXA black plates I got and those stuck around for more than a year. They started going microphonic and making noises so I ordered another pair (noisy) then another different vendor (blasts of white noise) and another set that arrived today (one is noisy as holy hell and one seems fine).

So where does one order preamp quality tunes that are quiet? Is there something I’m not requesting when ordering? Maybe dump
snd go solid state? I’m trying to be humorous because I’m pissed. Ha.
gochurchgo
CONTACT Quicksilver,  go to: http://quicksilveraudio.com/contact/

Just chatted with Mike Sanders at QS again over email a few times.  He wanted to re-share he "responds to all emails" and suggested people may not be using the correct email address if they are not seeing a response.  

Note:  I checked and see his current gmail address via the "contact" page on his website is NOT the same as the old one some of us may have had last yer.   See contact on his site for the correct one to use.  
I have used 12AU7 tubes in that Quicksilver to lower the gain! You should do a little research on your gear before making a purchase. There is nothing wrong with that QS preamp. You mismatched the amp and preamp!
@donvito I researched the hell out of it. You should read a thread before commenting in it. Go ahead and search. Let me know what you come up with: TLDR zero.

never said anything was wrong with it and in the original post I noted that I realized about the gain. 
Threads would be much shorter, were more contributors disposed to actually read what’s been previously discussed.      Seems ubiquitous, on most social media platforms.
Hard to get through 145 responses....