Classe' CP-500 Questions

Hello Folks,

I have not been around here lately(hung out in the Analog forum for a year or two) so I hope all is well with you.

I am probably going to buy a used CP-500 from a non Classe' dealer who took in as a trade-in. I have the following questions:

* The display button and Tape button on the remote do not produce a response from the unit. Anybody experience this? I did take the display setting off Never and it does go blank after 30 seconds as it should. I have my Tivoli clock radio working as a tuner plugged into the Tape input and the remote Tape button will not deselect it. Is there a reset button somewhere?
* In another thread folks said the funky background to the display (spots of different shapes/sizes) is normal. Anybody disagree?
* This unit is at least 5 years old. I am somewhat concerned about paying close to 2k US for something this old even though it looks new. Reliability an issue with these?
I am really enjoying the unit. It is neutral/clear with plenty of detail without being too analytical. I am sensitive to harshness.

BTW, I have it paired with a new Rotel 1582 that may have an upper mid peak and may have to go back. The Rotel does have enough hours on it now to be considered broken in.

Have a good whatever,
Hey Again,

Forgot to ask if anyone has heard the phono module. Cordesman thought it was pretty good.


So y'all mad at me or no CP-500 owners/former owners around? Would appreciate some help as I have yet to get Classe to call me back.

Should be getting a CA-2200 tomorrow to go with it. Rotel 1582 going back. Good amp but I am used to better construction and it has a bit of hardness int the mids.

Breaking in some Kimber VS biwire cable which sounds good cold.

Take care one and all,
So, got my CA-2200 today. Really nice, lost the hard mids and upper mid peak of the Rotel 1582. Surprising also lost some of the fullness(as in body of the instruments) and bass. Hopefully I will get some of that back as the Classe' runs in. It is a little sweet and a little polite but that does make it less fatiguing. It still has quite a bit of detail with nice air and stronger/detailed highs but not harsh . The Rotel had good clarity but as you might expect, the Class' has even more.

Guess I will email Classe' as they have not answered either of my voicemails. So far the CP-500 has been running 24x7 flawlessly except as noted above.

Y'all have some fun,

Anybody know what the secret code is to get a human at Classe'? I called again this morning and even tried a random person but got his voicemail.

I did leave another message and then emailed them. Hope my dealer stays in business in case I need help with the amp.

BTW, after a day or two of burning in, the amp is a bit more full but still not as full as the NAD M3 or Rotel 1582. Much nicer overall of course.

Hope y'all have much fun,

I have had the same problem with my CP-700. I sent the remote to Classe for reprogramming the chip inside.

You should call the B&W/Classe service to obtain a RMA number.


"I have had the same problem with my CP-700. I sent the remote to Classe for reprogramming the chip inside.

You should call the B&W/Classe service to obtain a RMA number."

As I stated, I could not get anyone at Classe' to answer or call me back.

I did get a call this morning from Robert Adam the customer service manager. What a nice guy (I know, Canadian). He answered some questions and volunteered info on my units. He is looking into the remote issue and I told him I would put in fresh batteries. I did a reset on the preamp and that did not help the remote issue. There is also a firmware update that I will apply.

Interestingly, my CA-2200 was sold to the dealer in 2005 as a demo unit so the warranty situation is messed up. It appeared to be new in the box so I will get with the dealer as they charged me full price but took back my Rotel 1582 past the 7 day return.

Thanks to YL for the reply,