Center Channel Speaker Conundrum


(Cross Post in Amps/Preamps, Home Theater, Digital, and Misc. Audio)  Conundrum for the group: I have a Marantz AV7005, probably seven or eight years old, which purports to resolve Dolby Digital Plus signals as one might receive through Netflix, Amazon Prime Video, and so forth.  Indeed, when playing such sources, the pictogram on the Marantz display screen reflects "Dolby Digital +," and the owner's manual lists DD+ as a supported, decodable, transmissible signal.  


Here is the problem — across different streaming devices (PS3, PS4, and now a new Roku unit) the center channel will not produce sound from Netflix or Prime Video programs.  Instead, the center channel signal apparently splits into the left and right front speakers (piggy-backing on the appropriate left and right front signals). 


Oddly enough, the Marantz’s display pictogram not only reflects the correct DD+ signal and codec, but all of the relevant speakers are illuminated as being recognized and fed, including the center channel (center, left and right fronts, left and right surrounds, and subwoofer are all shown as active).  Indeed, all of the other speaker channels play and sound fine, including the subwoofer. 



As for other potential contributors, the center speaker itself works fine, and when fed by the same AV7005 and amplifier connection, plays through multi channel stereo and other programs perfectly well.  Thus, I know both the speaker and amp channel operate correctly.  The speaker EQ is also set sensibly, with the center channel not suppressed unduly from a volume standpoint.  


So, does anyone else experience this?  Any thoughts on how to resolve this riddle? Thanks!


8abc64f2 6356 4c83 9984 54651f9b3ce5howaboutthat41
It sounds like you have “Phantom Center” configured somewhere, maybe specific to DD+.  That’s all I got, but I’m sure someone more familiar with your Marantz will chime in here.  Best of luck with this. 
I have a Denon AVR-X3600.  I had this happen after a recent update.  I fixed it by setting the Roku audio setting to Auto Passthrough instead of Auto Detect.  Then just make sure you have that input on your AVR set to Movie,  Dolby Audio, Dolby Surround or whatever Dolby your AVR shows as a choice.

This happened after an update a while ago.  I'm assuming a Marantz behaves pretty much like the Denon since they're cousins.

think you need to post this a few more times……as 4 wasn’t enough