Blown tube amp Sophia electric 91-01 need advise

Folks' I came home yesterday from work eager to sit in front my hifi system for some quality time. Turned on my preamp (shanling mc3000 tube stage) turned on my Sophia electrics and then turned on my olive 06hd. Almost immediately I heard harsh crackling sounds from left channel. I looked down on amps - to my sock and disbelief the left tube amp was in smoke!!! Here is what I saw: the beautiful 300b princess mesh tube was clearly blown, purple flickering light almost looked like it was about to go on fire and there was smoke coming out of the amp from around the base of rectifier tube, and near the hum control. The other monoblck Sophia seemed to be ok. I turned them both off immediately.

Before I call Sophia electric, any advise and initial diagnosis on what this could be about and what is the best and most cost effective way to address? Could it be a simple blown fuse? Blown tube? Or god forbid blown transformer?? Is it worth switching tubes with right channel or would that risk blowing the other 300b?

I am in great distress and in the meantime have retreated to my old sold state Aragon 2004 which sounds beautiful but mising the tube magic I have grown to love.

Hi Bob,

I have a Sophia Tube amp (MC300-A) and consider it to be the finest amplifier I have ever owned. It has had no problems over ten years of use. Were you ever able to get your fixed? Was there any damage to the speaker?
Could be a blown resistor that the bad tube took out. A good tech would be able to figure it out.
Sounds like the power tube arced and was able to damage a component, possibly the hum balanced control itself.

This should not be a big deal. The circuit is simple.