Audio Alchemy DDE v.3.0

I need help.
I own a Audio Alchemy DTI v.2.0 and a DDE v.3.0.

My problem is that the DDE won't get the status 'lock' if I feed my digital signal through the DTI which connected to the DDE although I still get analog output signal.
BUT if I feed the digital signal directly through the DDE (bypass the DTI), I get the 'lock' status o.k.
What wrong with my DDE? How to fix it?
Thank you.
I've had both these units.
I'm not sure I totally understand,if you have connected via the dti and you are getting music then it must just be a problem with the light-yes,no?
If not check the following....
Have you tried different digital connections via the dti?
To me if there is a problem it lies with the dti.
If you check both coax and optical via the dti and neither work then I suspect the dti is kaput.
Make sure your output and inputs (digital)are correct-easy to mess this up in these units.
Make sure when powering up,you put the dti on first.
Let us know how you go.
I have both of this unit, When this happen, you are
not on the right input or output connections.Ussually
the Kimber d60 works best and agdl.
Try using an I2s connection (the five pin connectors) between the two units. Monolithic sound sells cheap I2s cables.
If you use I2S you will not get a lock indication.

Good point Carlton I forgot that.
Would the original poster come back and indicate how he got on.
Thank you guys.
Having read all the suggestions you guys contributed I think my DTI is RIP. The system has been working well for years and just recently the the LED is not lit. If I connect the digital output from the transporter directly to the DDE, everything is OK. It works for both optical connection and coax connection.
Is there a chance to get my DTI fixed?