Apple Airport Express won't play WAV files

My music is all on my iMac HDD. It is connected over wireless network to an Airport Express, which is plugged into a Marantz SR7007 using an ethernet cable. When I attempt to play a WAV file, I get a message that says "File Format Error". How do I play WAV files on this system ?? Thanks
Since the Airport Express is an Apple product and designed to work with i-tunes. I think to play a WAV file a microsoft product you need a linking software such as Air Foil to play a wav file through your Airport.

I am not familiar with your type of setup, however, I will say that I believe that .wav files are natively compatible with iTunes. Are you running 16 or 24 bit files? What is your sample rate? Where ever your problem lies, I don't think it's with iTunes.
Have you contacted Apple? They are very good at helping. Go here: and click the phone icon in the upper right hand corner. Select Mac->Wireless
I downloaded Air Foil after reading Chuck's post (before the other posts were made). Now I'm further away than before. For some reason, Air Foil recognizes the wireless network and the Marantz receiver, but NOT the airport express. Now it won't play anything. airport express utility still says AE is connected to the network, and Internet radio still works. I won't have much time to work on it today, so I'll report back tomorrow. BTW, before I installed Aif Foil, the AE and the Marantz would successfully play CD FLAC files (16 bit, 44.1kHz) as well as 24 bit 96 KHz FLAC files. It would not play 24/96 WAV files.
Apple Support will help. It sounds like you need someone to walk you through the situation.
Thanks for all your suggestions. I have direction to go in now. I'll be out for a few days, but I will report back when I have something to report.
Back again. I figured you how to convert WAV and APE files to FLAC using XLD. Now I can play those files thru the AE, but only up to 16/44.1 kHz. If I try to play 24/88.2, or 24/96 FLAC files, I get lots of dropouts. Is this a limitation of the AE, or of my router ?
This thread on Apple forums sounds similar to your problem:
Airport Express - Digital audio output - and Jitter