Apple Airport Express to DAC


Hi,

I have an evolution 100A and 50CD. When I run digital audio through an apple express via toslink to the 50CD DAC, it sound great, but there is "skipping". I searched online and couldn't find an immediate cause of this.

I am running Apple Airport Express to a Creek EVO 50CD DAC via minijack to toslink optical cable.  There is intermittent "skipping" that I cannot figure out. If I run minijack to RCA on the amplifier (EVO 100A), there is no skipping.  I asked creek support and this was the conversation:

creek: It sounds like there’s an issue in using that type of cable. This is not a true way of using an optical signal. I would suggest using the jack to phono rca lead as this will use the DAC in your Creek unit rather than the built-in DAC of the Apple product.

me: I'm confused. Running optical signal to my creek DAC is wrong? You suggest running minijack to RCA on the EVO 100A amplifier? How does the EVO 50CD get the digital signal from the EVO 100A?

creek: An optical signal can only be transmitted down an optical cable that’s terminated with TOSLINK blocks at both ends.There are no digital signals past between the Evolution 50CD and Evolution 100A. The signal is only analogue; not digital between these devises. I would suggest running an RCA phono cable from the pre-amp output of your Evolution 100A and plugging that signal into the jack socket of the Airport Express.

me: but the minijack out on the airport express is a combo analog/optical output. (picture of back of airport express from apple website showing analog/optical port).

creek: /crickets

Can anyone explain what I'm doing wrong?  Thanks for your help.

Cable: FosPower (3 Feet) 24K Gold Plated Toslink to Mini Toslink Digital Optical S/PDIF Audio Cable with Metal Connectors & Strain-Relief PVC Jacket.

Airport Express: whatever the latest version was with firmware updated.

pandrus
maybe the buffer is getting filled up, causing the skipping
which buffer?
If you have the right cable, try running the analogue output of the Express to an input on the pre amp. This will tell you if it's a network issue or a cable issue.

You're not alone with this problem...

There's a lot of info available on Computer Audiophile and other websites to help troubleshooting this. Google "Apple Airport Express Streaming Issues"


I think the creek 100a is integrated.  no skipping if I run analog/rca to the 100a.
FYI - I changed a bunch of apple express settings and what finally did it for me was reverting to an earlier firmware (7.6.2).  Humming along this morning without skips...
nope.
I'm running AE (7.6.8) with no issues.  I had Wi-Fi drops until I switched to 5GHz router (dual band).  The only thing I can think of is, that either optical mini plug on the Toslink cable, or mini/Toslink adaptor (I use adaptor) have bad contact (too much distance) or dirt - causing reduction in light intensity.  Try different Toslink cable or different adaptor.
What adapter are you using?
Don't remember the brand - mini optical to Toslink, then 3' glass Toslink to DAC.
Found it:

https://www.amazon.com/gp/product/B0002MQGRM/ref=oh_aui_search_detailpage?ie=UTF8&psc=1

and the cable:

https://www.amazon.com/gp/product/B001D1A8KM/ref=oh_aui_search_detailpage?ie=UTF8&psc=1
sprayed the airport express and the toslink input on the DAC with canned air.  Still getting skipping using my minijack to toslink cable.  I ordered a minijack to RCA spdif cable before seeing your post.

if that doesn't work, the problem may be the airport express jack - i should try another airport express, huh.

i do like the look of the toslink/miniplug glass fiber cable at lifatec

http://www.lifatec.com/toslink2.html
Mini/Toslink cable might work better than adaptor+cable.  I found that blinking yellow light on the AE is a sign that firmware should be updated. (It stopped after update).  I'm not sure it changed anything since it worked fine before and after update.