Apple Airport Express oddity with new (to me) Arcam AVR350 receiver


Hi Folks, I'd appreciate any guidance as I'm stumped. Here's the deal:

I previously streamed iTunes - AE - optical cable - rotel rsp985 using the DAC in the rotel. 

I have upgraded the Rotel separates to an Arcam AVR350. Everything works through the Arcam optical EXCEPT my airport express. I've tried: cd player, macbook, apple tv and they all send a happy digital signal to the arcam, but the AE can only work with an analog signal. 

For troubleshooting, I have confirmed that the cable is good, the optical out of the AE is good (it worked fine on the rotel), the optical in on Arcam is good.

My only two possibilities are:

1) I damaged the optical out of the AE when unplugging from the rotel. (unlikely.) 
2) The arcam somehow cannot translate AE's signal


I called Arcam and apple and they are both stumped. 

any ideas?  
stevecuss
If your new DAC uses the Sabre chip (e.g. 9018) you're screwed. The latest generation AE fails with the Sabre.  I think it's a jitter issue. The older walwart AEs still work fine with the Sabre DAC. 

Even worse, the issue is AE firmware. Apple knows about this, but could give a sh@t. 
You can get yourself an older generation AE for cheap on eBay.  
Yeah, that might be my only option, or get an Apple TV 3rd Gen.  

I just bought a Grant Fidelity DAC-11 and it won't decode the digital out of the AEX either. I reconnected my older Rotel gear to the AEX and it works just fine. Really weird that some gear is more sensitive than others.