Anyone using the JPLAY app ?

I first heard about the JPLAY app on a posting in this forum a couple months ago.

It's recently been released for iOS by the JCAT group.

Because of my equipment I had  only been able to use M-Connect to stream to my Ifi Zen Stream.  I was using Tidal Connect with the Ifi Zen but I've since cancelled my Tidal account. 

Qobuz has sounded terrific via the M-Connect app into my Zen Stream but the app itself is uninspired to say the least. 

I've been using JPLAY for the past month or so and, while there's been a few bugs, the developers are releasing rapid fire updates to accommodate issues that come up.  

Overall it's been such an upgrade in terms of user enjoyment over using M-Connect.  Yes there are some issues.  I've been experiencing track skipping on occasions, but I know the dev team is working on that.

I love how you can have both your Tidal and Qobuz account on the JPLAY app and the search function allows you to select which record from which service and which version to play.  Also the metadata and any liner notes available are more more accessible with JPLAY.  Lastly, it's a beautiful looking app.

The cost for the app is about $54.

I hope they somehow figure out a way to include Idagio at some point.

Anyone else?



That’s what I get for reading too fast, sorry.

Ha ha we've all done it. Sometimes my problem is not reading too fast, but thinking too slow. (And yes, I know that's grammatically incorrect.)

I installed on the iphone last Friday. Oh man it brings my system to another level. I have been using mconnect for couple years but it is ended this week. My system is Bricasti M1SE DAC with network card. Minimserver runs on synology NAS. The down side is $50 every year :-(.

I no longer can access on my laptop . I have tried different options but still remains unobtainable.So I tried on my android phone and have the same issue. So has this website been compromised?

@bobby1945 - I'm able to access but it is marked as "Not Secure" in the Brave browser. Maybe you have some security software or your browser which is blocking the site.