Anyone have this problem?

Hello all.....I just recently purchased a new McIntosh MX 123. Looks and sounds great. I am having an issue though. While watching tv through the processor, when I change channels it drops the audio. I have to switch inputs and then switch back to get the audio back. This cannot be normal, or perhaps McIntosh assumed it would not be used to channel surf. Any experience or comments? 
Not sure I can help but if you are hooked up through HDMI, there are protocols that look for the next device in the chain. Your devices or processor may have a setting that turns off the change of devices. 
I have this happen occasionally (not Mac, I have Meridian) it seems that the audio handshake where it chooses the protocol fails. Where it is deciding DTS, or DD, or...

russ69....I am using HDMI. I have searched through settings for an option that might help the situation and cannot find anything.
ghdprentice...I agree with your possible diagnosis but cannot find a way to stop the behavior. My ten year old processor I was using did not have this issue.
Have implemented the latest firmware upgrade?You should not have this issue IMO
It is like the processor , when changing channels, stop using the former audio format . Then , it is not able to set the new format ( that 
may be the same ) . You have to go back and forth for the processor
to set the audio format.
Ask you dealer or communicate directly with McIntosh.
Go to McIntosh MX123 forum
maxwave....Yes, it has the latest firmware. I agree I should not have the issue, but this is the second MX 123 with the issue. I returned the first unit and got another. I assumed the first unit was defective but now I'm thinking it may be a design flaw. I have spoken with both the dealer and with McIntosh directly and both say they have not heard of this issue. I want to keep it because I am pleased with every other aspect of the processor. I will look to join the avs forum and post the concern there. 
It great when no one’s heard of (seen) something that is inplain sight.