Anthem & Xfinity

hello all, any anthem avm-30 & xfinity (Comcast) folks out there? I cant' get 5.1 surround while watching on-demand thur this unit. most on-demand tv shows play in 2-channel. but the unit displays 5.1 dolby d.
Do you get 5.1 surround with other channels. IOW, is the problem only with on-demand tv shows?
I think you are stuck with 2 channel on most on demand, unless listed as HD. Back to using prologic II?
Jjrenman: this problem is only with on demand shows. live & dvr-ed shows are great in 5.1.

Elevick: I have xfinity X1 service. and only watch HD programs. I though the 2-channel would at least give me prologic II.

I also have a emotive umc-200. all on demand shows are in 5.1 dolby digital!! it must be a hdmi thing. maybe no 5.1 thur optical.
"it must be a hdmi thing. maybe no 5.1 thur optical."

There was a recent thread that discussed this issue. IIRC, the bottom line is that there is not enough bandwith for 5.1 through optical.

Check out this thread. It may have the answer you seek.
Did you set your X-1 to surround sound ? its in the device setup menu. Also keep in mind there are still a few bugs with the X-1 platform but the good news its getting better with each update they do.
I suggest you definitively confirm with Xfinity that the audio is indeed being broadcast in 5.1 with audio coming from all channels. As others have noted, I have heard that many on-demand programming is only in stereo regardless of what the signal is to the processor. So before driving yourself nuts, confirm that to be the case. The fact that you are getting 5.1 from other channels almost confirms this. I highly doubt the issue is with the Anthem and it's not a bandwidth issue with toslink or S/PDIF. You can get 5.1 just fine through those. Bandwidth limitation over those is only normally confined to lossless codecs.
yes Jdub, this is driving me crazy. can't do 2-channel!
hello all, hbo is in 5.1 but regular on demand networks are in stereo. the emotiva displays 5.1 and plays all on demand shows in 5.1 thur hdmi. the anthem will only play stereo on demand regular networks thur optical.
hello all,

i'm getting rid of the anthem.
If this is only because of the tv issue , comcast has admitted its a bug, and a simple solution for now is to use an optical cable which is what I've used from the beginning and can report it has worked well for 5.1 sources but there are still some on demand programing that is indeed still only dolby prologic.
jdub, the anthem will not down grade to prologic. only 2-channel. the emotive is $600 or a receiver for around $500.
90% of my tv watching is with the anthem. live tv is great this is an on demand only issue.
this Yamaha RX-A720 is calling me.
I had an AVM 20v2 with old motorola dvr, you need to select a different sound mode when its only a 2/ch signal say PLII, Anthem's own or DTS NEO.
ok, i'll try that.
There's a new Anthem firmware beta update that lists as one of the items Dolby digital input signal not playing through surrounds. This may be the bug you're referring to but not sure. It's worth an email to Anthem support if you haven't reached out to them already
thanks internetmin, i spoke with anthem & updsted the processor. it took about 3hrs but updated. still have the same issuses. i found a buyer for the anthem in philly. going to get the yamaha rx a830. use this as a processor & keep my rotel 5-channel amp. hate going backward but this will work for the home.
hello all, after switching for anthem to Yamaha the same problem is happing. i'm getting the cable box switched on Friday. the Yamaha may get returned.