A new Apple TV Question

OK, where did I go wrong? I finally got around to installing a new Apple TV in my main rig. When I unplugged my original (which was working fine) from the main system and plugged it in to my second system, it is no longer recognized on iTunes (or at least not completely). The icon for Apple TV 1 (the original installation which I unplugged and installed in my second system) does not show up under "Devices" but does show up as "syncing" in the Apple TV section of Preferences.

OTOH, Apple TV 2 (the new one installed in my main system)shows up in both places and works fine. In Devices it shows the spinning arrows while syncing.

Adding insult to injury, Apple TV 2 does not show up as an available library on my iPod Touch, so now I can't use it as a remote (with the "Remote" app.)

ARRRRGH! Anybody got a clue? BTW, there is no video monitor available to set up the Apple TV 1 in my secondary system.
Have you checked the Apple TV forums on the Apple website? Just go to support then communities.
Are both Apple TV's on the same network? On my second system the AppleTv is connected to the LAN wirelessly. First system is wired LAN. With the wireless, there were firewall problems leading to iTunes not recognizing the AppleTv. There are fixes to this, but a quick way to test it out is to temporarily disable your firewall.
Thanks for the replies. Will check out the Apple Forums when I have a bit more time. What is strange is that I previously posted the question of whether you can disconnect the ATV and reconnect and was told by a couple of 'Goners that they hadn't had a problem, which I am sure is the case. So when I reconnected and it wasn't recognized I was very surprised. Apple TV 1 worked fine before I disconnected/reconnected, so I doubt it's a firewall problem, because I never had to fiddle with firewall connections either when I first installed ATV No. 1 or No. 2. To answer Dgaylin's question, both are on the same wireless network and No. 1 was sort of recognized but not fully.

Thanks again. I am always impressed by the generosity of this community in trying to help out. Regards to you both.
Just one other thought, which you may have already tried. AppleTVs are great but they do get confused every now and again. For example, I rented a moview on mine the other day and it wouldn't play it. Every time I tried, I got a white screen of death. Yes, I found the answer on the forums, and yes, you guessed it -- a hard reboot (meaning restore the factory settings). It's not that big a deal to set it up again.
If I remember correctly you can only sync to one iPod & one Apple TV. Something w. DRM.
Thanks for all the replies. Strangely, this has partially resolved itself. After almost a week, I noticed that somehow both Apple TV's are now recognized and up and running. I still haven't gotten my iPod Touch to work correctly. Now when I open "Remote", I get a white screen on the iPod for a few seconds, then it reverts back to to the screen showing all my icons. Any ideas? I think I may need to reset the Touch back to factory settings and start over. Progress at least though
Have you tried to contact apple support? Maybe you need a firmware update.