AudiogoN
Search Buy Sell Learn MyPage
 Learn > Forums > Misc Audio > 1169383907  Start New Thread | Log In | Bookmark This

  Which Power Conditioner is best at eliminating Hum
My system consists of a Conrad Johnson MF5600 5 ch amp, Premier 17LS Preamp, BelCanto PrePro and Esoteric 50S...all connected with Cardas Neutral Reference. When I put the system together I had a loud and constant hum. I've read that a "balanced power" conditioner would solve the hum...is that correct? If so, which brand of conditioner is best at eliminating hum WITHOUT reducing the overall musicality of the system?
Thanks everyone.
Riccap  (Threads | Answers | This Thread)

01-21-07
  Responses
01-21-07: Metralla
You should be able to eliminate that "ground loop" without requiring a power conditioner.

Regards,

Metralla  (System | Answers | This Thread)


01-21-07: Rx8man
I had the same problem WITH a conditioner.

I lifted the ground on the inside of my tube preamp from the IEC, worked for me.

Rx8man  (Threads | Answers | This Thread)


01-21-07: Reubent
You should not need a power conditioner to prevent hum. Typically hum is caused by a ground loop. Often it is a result of connecting cable TV into your system or plugging into outlets that have different ground potentials for some reason.

The easy troublshooting tips are:

1. disconnect cable TV or satellite Coax from your system.

2. connect your entire system into the same quad/dual outlet using a power strip.

If either of these activities resolve the hum issue, you know the problem is a ground loop and you can work to resolve it. If it's the coax, place a ground loop isolator in line. There are many available including one from radio shack, a jensen unit and the magic block from Mondial. They range in price from a few bucks to about $90 for the Mondial. If connecting all of the components into the same outlet solves the problem, you have an electrical system grounding issue which can be resolved by an electricial.

Lifting the ground on one or more of the components could also resolve the issue.

TIC

Reubent  (System | Threads | Answers | This Thread)


01-21-07: Tvad
I agree with all the above.

If your component's transformer is humming (not humming through the loudspeakers), then the new power product from CI Audio should take care of that problem, or you could try the PS Audio Humbuster. I believe both products remove DC from the line, which causes tranformers to buzz/hum.

Tvad  (Threads | Answers | This Thread)


01-21-07: Zar
I just sent out my PS-300 to be modified. I plugged my amp and pre in the dedicated line and heard a hum. I removed the pre and plugged a Monster power strip in to the line (Ps 300 was sharing with my amp)hum was gone. Never heard one bit of hum with the Power Plant as well. BTW I have noticed a smaller sound stage and loss of detail without my Ps Audio. I'm going to be watching more movies in the next couple of weeks.
Zar  (System | Reviews | Threads | Answers | This Thread)


01-22-07: Cytocycle
Welcome to Conrad Johnson equipment... start lifting grounds and good luck... I used a PS 300 and another balanced conditioner and still the hum persisted..

Like other people said , if you have a Cable connection disconnect that coax. If that doesn't work, start lifing the ground at the preamp with a cheater plug, if that doesn't help, lift the next component and leaving the amps for the last.

Cytocycle  (Threads | Answers | This Thread)


  Post your response
Subject


Your response

No html, but you may use markup tags


Username
Members only

Password